summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2018-05-19 12:03:46 +0300
committerMantas Mikulėnas2018-05-19 12:03:46 +0300
commit63db4efe5ae79afdb5889cbd49dff35c13e16cbf (patch)
treeb92d4ad4b9944366cdabbc79a70a1319a2061b19
parent71557afefe7ae871c50869d661bd1d88724dcfbb (diff)
downloadaur-63db4efe5ae79afdb5889cbd49dff35c13e16cbf.tar.gz
move to git+https and add a systemd unit
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58601166831d..ceb147d9bcbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Dan Fuhry <dan@fuhry.us>
pkgname=kcrap-lnf
pkgver=0.2.3+grawity1
-pkgrel=4
+pkgrel=5
_krbver=1.16
arch=('i686' 'x86_64')
pkgdesc="Kerberos Challenge Response Authentication Protocol"
@@ -12,9 +12,12 @@ url="http://www.spock.org/kcrap/"
conflicts=('kcrap')
provides=("kcrap=${pkgver%+*}")
replaces=('kcrap')
-source=("git://github.com/grawity/kcrap-lnf"
- "git://github.com/krb5/krb5#tag=krb5-${_krbver}-final")
-sha1sums=(SKIP SKIP)
+source=("git+https://github.com/grawity/kcrap-lnf"
+ "git+https://github.com/krb5/krb5#tag=krb5-${_krbver}-final"
+ "kcrap.service")
+sha256sums=('SKIP'
+ 'SKIP'
+ '100be82d33162072f2f1de79f4b7ac54baa6e1c673d986dee7ebf341920823d6')
backup=('etc/kcrap_server.conf')
prepare() {
@@ -43,6 +46,7 @@ package() {
mv "${pkgdir}/usr/sbin/kcrap_server" "${pkgdir}/usr/bin/kcrap_server"
rm -rf "${pkgdir}/usr/sbin"
chmod -x "${pkgdir}/usr/include/kcrap.h"
+ install -Dm0644 "${srcdir}/kcrap.service" "${pkgdir}/usr/lib/systemd/system/kcrap.service"
}
# vim: ft=sh:ts=2:sw=2:et: