summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-01 23:19:39 +0000
committerJoão Figueiredo2021-02-01 23:19:39 +0000
commit83ba5292c2d863525e217d222a60a44dab61c346 (patch)
treefae93fb9803620035275f3497ca2845d08c40647
parent02b5fe7f906a49acc62ff5bbbf18dc684456ba36 (diff)
downloadaur-83ba5292c2d863525e217d222a60a44dab61c346.tar.gz
Merged with official ABS kdbusaddons PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
2 files changed, 33 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90d152e07205..34a093f41093 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,24 @@
pkgbase = kdbusaddons-git
pkgdesc = Addons to QtDBus
- pkgver = v5.71.0.rc1.r1.g756b052
- pkgrel = 2
- url = https://projects.kde.org/projects/frameworks/kdbusaddons
- arch = i686
+ pkgver = 5.79.0_r338.g532309d
+ pkgrel = 1
+ url = https://community.kde.org/Frameworks
arch = x86_64
+ groups = kf5-git
license = LGPL
- makedepends = extra-cmake-modules-git
makedepends = git
+ makedepends = extra-cmake-modules-git
makedepends = qt5-tools
+ makedepends = clang
+ makedepends = python-pyqt5
+ makedepends = doxygen
+ makedepends = sip4
depends = qt5-x11extras
+ optdepends = python-pyqt5: for the Python bindings
provides = kdbusaddons
conflicts = kdbusaddons
source = git+https://github.com/KDE/kdbusaddons.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = kdbusaddons-git
diff --git a/PKGBUILD b/PKGBUILD
index 123a8d08e477..9353e1330a82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,37 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+# Merged with official ABS kdbusaddons PKGBUILD by João, 2021/02/01 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=kdbusaddons-git
-pkgver=v5.71.0.rc1.r1.g756b052
-pkgrel=2
+pkgver=5.79.0_r338.g532309d
+pkgrel=1
pkgdesc='Addons to QtDBus'
-arch=('i686' 'x86_64')
-url='https://projects.kde.org/projects/frameworks/kdbusaddons'
-license=('LGPL')
-depends=('qt5-x11extras')
-makedepends=('extra-cmake-modules-git' 'git' 'qt5-tools')
-conflicts=(kdbusaddons)
-provides=(kdbusaddons)
-source=('git+https://github.com/KDE/kdbusaddons.git')
-md5sums=('SKIP')
+arch=($CARCH)
+url='https://community.kde.org/Frameworks'
+license=(LGPL)
+depends=(qt5-x11extras)
+makedepends=(git extra-cmake-modules-git qt5-tools clang python-pyqt5 doxygen sip4)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+optdepends=('python-pyqt5: for the Python bindings')
+groups=(kf5-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- mkdir -p build
+ _ver="$(grep -m1 "set(KF5\?_VERSION" CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../kdbusaddons \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF
- make
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}