summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Lauinger2015-07-12 03:58:12 +0200
committerJohannes Lauinger2015-07-12 03:58:12 +0200
commitb199e4370d18e0141a7333d36f015bdea5e3125f (patch)
treee563d4972c7671f6844eb98655856d003bce9ce7
downloadaur-b199e4370d18e0141a7333d36f015bdea5e3125f.tar.gz
first version
-rw-r--r--.SRCINFO19
-rw-r--r--Makefile.patch20
-rw-r--r--PKGBUILD31
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eebc45a3addc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kdbx-viewer
+ pkgdesc = ncurses GUI to browse and command-line tool to dump all contents of a KeePass2 Database files (kdbx)
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/max-weller/kdbx-viewer
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = ncurses
+ depends = libgcrypt
+ depends = zlib
+ depends = expat
+ depends = stfl
+ provides = kdbxviewer
+ source = git+https://github.com/max-weller/kdbx-viewer.git
+ md5sums = SKIP
+
+pkgname = kdbx-viewer
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..eb60b8c09e00
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,20 @@
+--- Makefile 2015-07-12 03:09:46.789759992 +0200
++++ Makefile 2015-07-12 03:17:07.613991170 +0200
+@@ -2,14 +2,10 @@
+ LIBKX9R_CODE = libcx9r/aes256.c libcx9r/base64.c libcx9r/kdbx.c libcx9r/key_tree.c libcx9r/salsa20.c libcx9r/sha256.c libcx9r/stream.c libcx9r/util.c
+ DEFINES = -DHAVE_STDINT_H -DGCRYPT_WITH_SHA256 -DGCRYPT_WITH_AES -DBYTEORDER=1234 -DHAVE_EXPAT
+
+-#libcx9r.o: $(LIBKX9R_CODE)
+-# gcc -c -o libcx9r.o -I./include/ $(DEFINES) $(LIBKX9R_CODE) -lgcrypt -lexpat -lz
+-
+-#kdbxviewer: libcx9r.o src/main.c
+-# gcc -o kdbxviewer -I./include/ main.c libcx9r.o
+-
+ kdbxviewer: $(LIBKX9R_CODE) src/main.c src/tui.c src/mainWindow.stfl src/helper.c
+ mkdir -p bin
+- cp src/mainWindow.stfl bin/mainWindow.stfl
+ gcc -g -o bin/kdbxviewer -I./include/ -I./libcx9r/ src/main.c src/helper.c $(DEFINES) $(LIBKX9R_CODE) src/tui.c -lgcrypt -lexpat -lz -lstfl -lncursesw -lmenu -Wno-pointer-sign
+
++install:
++ mkdir -p $(DESTDIR)/usr/bin
++ cp bin/kdbxviewer $(DESTDIR)/usr/bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4e0814c204b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Johannes Lauinger <johannes@lauinger-it.de>
+
+pkgname=kdbx-viewer
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="ncurses GUI to browse and command-line tool to dump all contents of a KeePass2 Database files (kdbx)"
+arch=('x86_64')
+url="https://github.com/max-weller/kdbx-viewer"
+license=('GPL')
+depends=('ncurses' 'libgcrypt' 'zlib' 'expat' 'stfl')
+makedepends=('git')
+provides=("kdbxviewer")
+install=
+changelog=
+source=("git+https://github.com/max-weller/kdbx-viewer.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p0 < ../../Makefile.patch
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}