summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorleo_sk2021-12-13 22:20:49 +0530
committerleo_sk2021-12-13 22:20:49 +0530
commit44e338c5968b5f0dd8cb27b5dadcd6090ed66417 (patch)
treea0e15d1c1dee2aa5c07fdd3234ecb3d2bf92fa37
downloadaur-44e338c5968b5f0dd8cb27b5dadcd6090ed66417.tar.gz
First Commit
I am a complete beginner at git. Hopefully this works. I am just uploading the .SRCINFO and PKGBUILD.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c091a6ac2c26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kde-rounded-corners
+ pkgdesc = Round the corners of windows
+ pkgver = 1.0
+ pkgrel = 1.0
+ url = https://github.com/matinlotfali/KDE-Rounded-Corners
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = kinit
+ makedepends = git
+ depends = kwin
+ source = git+https://github.com/matinlotfali/KDE-Rounded-Corners
+ sha256sums = SKIP
+
+pkgname = kde-rounded-corners
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e60c5ee042b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Leo sk <sk.griffinix@gmail.com>
+pkgname=kde-rounded-corners
+pkgver=1.0
+pkgrel=1.0
+pkgdesc="Round the corners of windows"
+arch=('x86_64')
+url="https://github.com/matinlotfali/KDE-Rounded-Corners"
+license=('GPL3')
+depends=(kwin)
+makedepends=(extra-cmake-modules cmake qt5-tools kinit git)
+source=(git+https://github.com/matinlotfali/KDE-Rounded-Corners)
+sha256sums=('SKIP')
+
+prepare() {
+ mkdir -p qt5build
+}
+
+build() {
+ cd qt5build
+ cmake ../KDE-Rounded-Corners/ -DCMAKE_INSTALL_PREFIX=/usr -DQT5BUILD=ON
+ make
+}
+
+package() {
+ cd qt5build
+ make DESTDIR="$pkgdir" install
+}