summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-06-08 13:04:32 +0200
committerFadeMind2015-06-08 13:04:32 +0200
commit43d5957457960cf1e5151893d22fcd79b094a324 (patch)
treef2f1b54aecc45cab6f45337007b4e88024ddba9f
downloadaur-43d5957457960cf1e5151893d22fcd79b094a324.tar.gz
0.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--pastebinit.desktop34
-rw-r--r--pastebinit.install15
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38e418ac1018
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kde-servicemenus-pastebinit
+ pkgdesc = A KDE service menu for sending files to pastebin like sites
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://example.com
+ install = pastebinit.install
+ arch = any
+ license = GPL
+ depends = kdebase-dolphin
+ depends = xclip
+ depends = pastebinit
+ source = pastebinit.desktop
+ sha256sums = db67bbf3ab0c831504dd95622199025b5a63d6849d2b82aafe6dd3e009fdac4a
+
+pkgname = kde-servicemenus-pastebinit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..766e4b16ace9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+
+pkgname=kde-servicemenus-pastebinit
+pkgver=0.1
+pkgrel=1
+pkgdesc="A KDE service menu for sending files to pastebin like sites"
+url='http://example.com'
+arch=('any')
+license=('GPL')
+depends=('kdebase-dolphin' 'xclip' 'pastebinit')
+source=('pastebinit.desktop')
+install=pastebinit.install
+sha256sums=('db67bbf3ab0c831504dd95622199025b5a63d6849d2b82aafe6dd3e009fdac4a')
+
+package() {
+ install -dm755 ${pkgdir}/usr/share/kde4/services/ServiceMenus/
+ install -D -m644 pastebinit.desktop ${pkgdir}/usr/share/kde4/services/ServiceMenus/
+}
diff --git a/pastebinit.desktop b/pastebinit.desktop
new file mode 100644
index 000000000000..5ea1a23e0177
--- /dev/null
+++ b/pastebinit.desktop
@@ -0,0 +1,34 @@
+[Desktop Entry]
+Type=Service
+ServiceTypes=KonqPopupMenu/Plugin
+MimeType=text/plain;
+Actions=paste
+X-KDE-StartupNotify=false
+X-KDE-Priority=TopLevel
+
+[Desktop Action paste]
+Name=Send to paste server
+Name[pl]=Wyƛlij na serwer
+Exec=cat %u | pastebinit -b http://paste2.org | xclip -selection clipboard
+Icon=edit-paste
+
+# Additional working websites:
+# - cxg.de
+# - fpaste.org
+# - lpaste.net
+# - p.defau.lt
+# - paste.debian.net
+# - paste.drizzle.org
+# - paste.kde.org
+# - paste.openstack.org
+# - paste.pound-python.org
+# - paste.ubuntu.com
+# - paste.ubuntu.org.cn
+# - paste2.org
+# - pastebin.com
+# - pastebin.mate-desktop.org
+# - pb.daviey.com
+# - slexy.org
+# - sprunge.us
+
+# Credits of Exec: NetBit73
diff --git a/pastebinit.install b/pastebinit.install
new file mode 100644
index 000000000000..5c36f07c0fe6
--- /dev/null
+++ b/pastebinit.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo
+ echo " In default this service will be sent text to paste2.org"
+ echo " If You want change it edit a file"
+ echo " /usr/share/kde4/services/ServiceMenus/pastebinit.desktop"
+ echo
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}