summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarnabe2022-10-04 23:23:12 -0300
committerBarnabe2022-10-04 23:23:12 -0300
commit5f6bafa578328ced5f4e124c7c5afea05a3d0d0b (patch)
tree4869a2f641b89482e25940c3041c420ef3975588
downloadaur-5f6bafa578328ced5f4e124c7c5afea05a3d0d0b.tar.gz
fist
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bc4977507d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = kde-snap-assist
+ pkgdesc = This KWin script for KDE Plasma suggests other window thumbnails on snap. It tries to replicate the famous Windows 10/11 feature of the same name.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/emvaized/kde-snap-assist
+ arch = any
+ license = GPLv3
+ depends = kwin
+ source = git+https://github.com/emvaized/kde-snap-assist
+ md5sums = SKIP
+
+pkgname = kde-snap-assist
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..167980e52c62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Barnabe di Kartola
+
+pkgname=kde-snap-assist
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="This KWin script for KDE Plasma suggests other window thumbnails on snap. It tries to replicate the famous Windows 10/11 feature of the same name."
+arch=(any)
+url="https://github.com/emvaized/kde-snap-assist"
+license=(GPLv3)
+depends=(kwin)
+source=("git+${url}")
+md5sums=(SKIP)
+
+pkgver() {
+ cd kde-snap-assist
+ vergit=$(git tag | sort | tail -n1 | sed 's|v||')
+ echo $vergit
+}
+
+package() {
+# cd $srcdir/KWin-window-positioning-scripts
+ mkdir -p "${pkgdir}/usr/share/kwin/scripts/"
+ cp -R ${srcdir}/${pkgname} "${pkgdir}/usr/share/kwin/scripts/"
+ rm -r "${pkgdir}/usr/share/kwin/scripts/${pkgname}/.git"
+ rm -r "${pkgdir}/usr/share/kwin/scripts/${pkgname}/.github"
+}