summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-27 18:26:00 +0200
committerGoliathLabs2020-05-27 18:26:00 +0200
commit246f54f299cbe8b2595658885db635e9d8b5190e (patch)
treecdf33a6a416caee857c42c370fbd038fd26dd368
parentce7a3b351d24c6ebdc103dc14a726e1eae952e7c (diff)
downloadaur-246f54f299cbe8b2595658885db635e9d8b5190e.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 31 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c29d67a3af4..8824507e510c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = kde-syndication-git
pkgdesc = RSS/Atom parser library
- pkgver = r542.cdc0e3f
+ pkgver = r766.4e90576
pkgrel = 1
- url = https://projects.kde.org/projects/kde/pim/syndication
+ url = https://community.kde.org/Frameworks
arch = i686
arch = x86_64
license = LGPL
- makedepends = extra-cmake-modules-git
+ makedepends = extra-cmake-modules
+ makedepends = doxygen
makedepends = git
- makedepends = python
- depends = kio
+ makedepends = qt5-tools
+ makedepends = qt5-doc
+ depends = kcodecs
provides = kde-syndication
+ provides = syndication
conflicts = kde-syndication
- source = git://anongit.kde.org/syndication.git
- md5sums = SKIP
+ source = git+https://github.com/KDE/syndication.git
+ sha256sums = SKIP
pkgname = kde-syndication-git
diff --git a/PKGBUILD b/PKGBUILD
index bfb8b5d1c6af..41683d77e3c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,42 @@
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
-_gitname=syndication
-pkgname=kde-$_gitname-git
-pkgver=r542.cdc0e3f
+_pkgname=syndication
+pkgname=kde-$_pkgname-git
+pkgver=r766.4e90576
pkgrel=1
pkgdesc="RSS/Atom parser library"
arch=('i686' 'x86_64')
-url="https://projects.kde.org/projects/kde/pim/$_gitname"
+url="https://community.kde.org/Frameworks"
license=('LGPL')
-depends=('kio')
-makedepends=('extra-cmake-modules-git' 'git' 'python')
-conflicts=("kde-$_gitname")
-provides=("kde-$_gitname")
-source=("git://anongit.kde.org/$_gitname.git")
-md5sums=('SKIP')
+depends=(kcodecs)
+makedepends=(extra-cmake-modules doxygen git qt5-tools qt5-doc)
+conflicts=("kde-$_pkgname")
+provides=("kde-$_pkgname" "syndication")
+source=("git+https://github.com/KDE/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd $srcdir/$_pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
+ cd $srcdir/$_pkgname
mkdir -p build
}
build() {
- cd build
- cmake ../$_gitname \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cd $srcdir/$_pkgname/build
+ cmake ../ \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
make
}
package() {
- cd build
+ cd $srcdir/$_pkgname/build
make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING.LIB "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}