summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:43:50 +0200
committerAntonio Rojas2015-06-08 22:43:50 +0200
commitce7a3b351d24c6ebdc103dc14a726e1eae952e7c (patch)
tree40527c81e0bc3d87ef9dddb6995b8ab7a8d4bf53
downloadaur-ce7a3b351d24c6ebdc103dc14a726e1eae952e7c.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c29d67a3af4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kde-syndication-git
+ pkgdesc = RSS/Atom parser library
+ pkgver = r542.cdc0e3f
+ pkgrel = 1
+ url = https://projects.kde.org/projects/kde/pim/syndication
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules-git
+ makedepends = git
+ makedepends = python
+ depends = kio
+ provides = kde-syndication
+ conflicts = kde-syndication
+ source = git://anongit.kde.org/syndication.git
+ md5sums = SKIP
+
+pkgname = kde-syndication-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfb8b5d1c6af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+_gitname=syndication
+pkgname=kde-$_gitname-git
+pkgver=r542.cdc0e3f
+pkgrel=1
+pkgdesc="RSS/Atom parser library"
+arch=('i686' 'x86_64')
+url="https://projects.kde.org/projects/kde/pim/$_gitname"
+license=('LGPL')
+depends=('kio')
+makedepends=('extra-cmake-modules-git' 'git' 'python')
+conflicts=("kde-$_gitname")
+provides=("kde-$_gitname")
+source=("git://anongit.kde.org/$_gitname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$_gitname \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}