summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-10-14 17:26:28 +0200
committerLuca Weiss2016-10-14 17:26:28 +0200
commitad0e9209322e049478de36799faf175c7d77f0ce (patch)
treec2541553058dc90554b7faa0b38ee957d610aa4e
downloadaur-ad0e9209322e049478de36799faf175c7d77f0ce.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84999432c1ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Oct 14 15:26:14 UTC 2016
+pkgbase = kde1-kdebase
+ pkgdesc = Historical copy of the base applications module of KDE 1, adapted to compile on modern systems (circa. 2016)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/KDE/kde1-kdebase
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = qt1
+ depends = kde1-kdelibs
+ depends = libjpeg
+ depends = libtiff
+ source = https://github.com/KDE/kde1-kdebase/archive/07492489711904daf165c633549883000a71295a.zip
+ sha256sums = 8f2f84b941af1b018ae4a86d41e6ff3a7e952254cfae32bc959c797fe49ae128
+
+pkgname = kde1-kdebase
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..820bb4a19c75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Luca Weiss <WEI16416 (at) spengergasse (dot) at>
+
+pkgname=kde1-kdebase
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Historical copy of the base applications module of KDE 1, adapted to compile on modern systems (circa. 2016)"
+arch=('i686' 'x86_64')
+url="https://github.com/KDE/kde1-kdebase"
+license=("GPL2")
+depends=("qt1" "kde1-kdelibs" "libjpeg" "libtiff") # TODO : Fill
+_commit="07492489711904daf165c633549883000a71295a"
+source=("https://github.com/KDE/$pkgname/archive/$_commit.zip")
+sha256sums=('8f2f84b941af1b018ae4a86d41e6ff3a7e952254cfae32bc959c797fe49ae128')
+
+prepare() {
+ cd $srcdir/$pkgname-$_commit
+}
+
+build() {
+ cd $srcdir/$pkgname-$_commit
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_LIBRARY_PATH='/opt/kde1/lib64'
+ make
+}
+
+package() {
+ # TODO : Fix icons missing
+ cd $srcdir/$pkgname-$_commit
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd ..
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+
+# vim:set ts=2 sw=2 et: