summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2020-10-03 13:13:31 +0200
committerLuca Weiss2020-10-03 13:13:31 +0200
commit4b9d4a527c020c22b99bfc7130f7029fdce981ca (patch)
tree291a01a45649831d437f3b09831a2b2f5ab7b3c5
parent82d111703b939bb3b311ce4a8597876d534b5a7e (diff)
downloadaur-4b9d4a527c020c22b99bfc7130f7029fdce981ca.tar.gz
upgpkg: kde1-kdebase-git 1.1.2r6137.849cc4d1a-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2800fa779c9..d3b8ae62d7ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = kde1-kdebase-git
pkgdesc = Historical copy of the base applications module of KDE 1, adapted to compile on modern systems (circa. 2016)
- pkgver = 1.1.2r6075.a40a9a0de
+ pkgver = 1.1.2r6137.849cc4d1a
pkgrel = 1
- url = https://quickgit.kde.org/?p=kde1-kdebase.git
+ url = https://invent.kde.org/historical/kde1-kdebase
arch = i686
arch = x86_64
groups = kde1
@@ -14,9 +14,12 @@ pkgbase = kde1-kdebase-git
depends = libjpeg
depends = libtiff
depends = perl
+ depends = pulseaudio
+ depends = glu
+ depends = libxpm
provides = kde1-kdebase
conflicts = kde1-kdebase
- source = git://anongit.kde.org/kde1-kdebase.git
+ source = git+https://invent.kde.org/historical/kde1-kdebase.git
md5sums = SKIP
pkgname = kde1-kdebase-git
diff --git a/PKGBUILD b/PKGBUILD
index 05bc43eb391a..21e2c6cc4c1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
-# Maintainer: Vaporeon <vaporeon@vaporeon.io>
-# Contributor: Luca Weiss <WEI16416 (at) spengergasse (dot) at>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contributor: Vaporeon <vaporeon@vaporeon.io>
pkgname=kde1-kdebase-git
-pkgver=1.1.2r6075.a40a9a0de
+pkgver=1.1.2r6137.849cc4d1a
pkgrel=1
pkgdesc="Historical copy of the base applications module of KDE 1, adapted to compile on modern systems (circa. 2016)"
arch=('i686' 'x86_64')
-url="https://quickgit.kde.org/?p=kde1-kdebase.git"
+url="https://invent.kde.org/historical/kde1-kdebase"
license=("GPL2")
groups=('kde1')
-depends=('qt1' 'kde1-kdelibs' 'libjpeg' 'libtiff' 'perl')
+depends=('qt1' 'kde1-kdelibs' 'libjpeg' 'libtiff' 'perl' 'pulseaudio' 'glu' 'libxpm')
makedepends=('cmake' 'git')
provides=('kde1-kdebase')
conflicts=('kde1-kdebase')
-source=("git://anongit.kde.org/kde1-kdebase.git")
+source=("git+https://invent.kde.org/historical/kde1-kdebase.git")
md5sums=('SKIP')
pkgver() {
@@ -31,13 +31,15 @@ prepare() {
build() {
cd build
- cmake "$srcdir"/kde1-kdebase -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_LIBRARY_PATH='/opt/kde1/lib'
+ cmake ../kde1-kdebase \
+ -DCMAKE_INSTALL_PREFIX='/usr'
make
}
package() {
cd build
make DESTDIR="$pkgdir/" install
- cd "$srcdir"/kde1-kdebase
- install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+
+ cd ../kde1-kdebase
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}