summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-09-28 10:10:33 +0200
committerMartin T. H. Sandsmark2020-09-28 10:10:33 +0200
commit8f7c471a4dc65e8ef710dc2af3c621708aeaf864 (patch)
treef64afc15865233d52debeec993c2ab704952a1b3
parent34fe846e88824eb063b2b8c62586dec186195efc (diff)
downloadaur-8f7c471a4dc65e8ef710dc2af3c621708aeaf864.tar.gz
fix build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9388b571a2a4..04cf949bf29f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kde1-kdegraphics-git
- pkgdesc = Historical copy of the graphics module of KDE 1, adapted to compile on modern systems (circa. 2016)
+ pkgdesc = Historical copy of the graphics module of KDE 1, adapted to compile on modern systems
pkgver = 1.1.2r1129.170e6a7
pkgrel = 1
url = https://quickgit.kde.org/?p=kde1-kdegraphics.git
@@ -10,7 +10,6 @@ pkgbase = kde1-kdegraphics-git
makedepends = cmake
makedepends = git
depends = kde1-kdelibs
- depends = giflib
provides = kde1-kdegraphics
conflicts = kde1-kdegraphics
source = git+https://github.com/KDE/kde1-kdegraphics.git
diff --git a/PKGBUILD b/PKGBUILD
index 7efdc222cf51..53dc148cf1ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: Martin
-pkgname=kde1-kdegraphics-git
+_module=graphics
+pkgname=kde1-kde${_module}-git
pkgver=1.1.2r1129.170e6a7
pkgrel=1
-pkgdesc="Historical copy of the graphics module of KDE 1, adapted to compile on modern systems (circa. 2016)"
-arch=('i686' 'x86_64')
-url="https://quickgit.kde.org/?p=kde1-kdegraphics.git"
+pkgdesc="Historical copy of the $_module module of KDE 1, adapted to compile on modern systems"
+arch=(i686 x86_64)
+url="https://quickgit.kde.org/?p=kde1-kde${_module}.git"
license=("GPL2")
-groups=('kde1')
-depends=('kde1-kdelibs' 'giflib')
-makedepends=('cmake' 'git')
-provides=('kde1-kdegraphics')
-conflicts=('kde1-kdegraphics')
-source=("git+https://anongit.kde.org/kde1-kdelibs.git")
-md5sums=('SKIP')
+groups=(kde1)
+depends=(kde1-kdelibs giflib)
+makedepends=(cmake git)
+provides=(kde1-kde${_module})
+conflicts=(kde1-kde${_module})
+
+# Mirror
+source=("git+https://github.com/KDE/kde1-kde${_module}.git")
+#source=("git+https://anongit.kde.org/kde1-kde${_module}.git")
-# Mirror, in case it fails:
-#source=("git+https://github.com/KDE/kde1-kdegraphics.git")
+md5sums=('SKIP')
pkgver() {
- cd kde1-kdegraphics
+ cd kde1-kde${_module}
printf "1.1.2r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -33,13 +35,13 @@ prepare() {
build() {
cd build
- cmake "$srcdir"/kde1-kdegraphics -DCMAKE_INSTALL_PREFIX='/usr'
+ cmake "$srcdir"/kde1-kde${_module} -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd build
make DESTDIR="$pkgdir/" install
- cd "$srcdir"/kde1-kdegraphics
+ cd "$srcdir"/kde1-kde${_module}
install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}