summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-10-14 22:23:27 +0200
committerLuca Weiss2016-10-14 22:23:27 +0200
commitc99f17d82a05fa967de9159996a14c33117b0ffa (patch)
tree35bdc404e3d76440b9a0cdc169b4f3f5b6cb6da9
parentc1eaacfb697a77d7a8cb63a633e64f15bfa122b6 (diff)
downloadaur-c99f17d82a05fa967de9159996a14c33117b0ffa.tar.gz
Add patch and bump to pkgrel 2
-rw-r--r--.SRCINFO6
-rw-r--r--KDE1Macros.patch33
-rw-r--r--PKGBUILD13
3 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b529566dad6a..c8293675412c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 14 16:55:53 UTC 2016
+# Fri Oct 14 20:23:16 UTC 2016
pkgbase = kde1-kdelibs
pkgdesc = Historical copy of the libraries module of KDE 1, adapted to compile on modern systems (circa. 2016)
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KDE/kde1-kdelibs
arch = i686
arch = x86_64
@@ -16,7 +16,9 @@ pkgbase = kde1-kdelibs
depends = libjpeg-turbo
depends = libtiff
source = https://github.com/KDE/kde1-kdelibs/archive/98b923b0a56423c6de5c5f2f68f457249b3e3cf6.zip
+ source = KDE1Macros.patch
sha256sums = be19075ccddb1141267cc445a3025ebb4654d0dc4e928580c571f16c699c59a6
+ sha256sums = d7adbb94ba65fc0d37c5e8ad4975a2c550562dae9131ff23086507a17d4cdba9
pkgname = kde1-kdelibs
diff --git a/KDE1Macros.patch b/KDE1Macros.patch
new file mode 100644
index 000000000000..79c231177a5c
--- /dev/null
+++ b/KDE1Macros.patch
@@ -0,0 +1,33 @@
+80a81
+> endforeach()
+84c85,91
+< function (install_icon icon targetdir)
+---
+> function (install_icon_int icon targetdir absolutepath)
+> if(absolutepath)
+> set(targetpath ${targetdir})
+> else()
+> set(targetpath "${KDE1_ICONDIR}/${targetdir}")
+> endif()
+>
+86c93
+< install(FILES ${icon} DESTINATION ${KDE1_ICONDIR}/${targetdir} RENAME ${icon})
+---
+> install(FILES ${icon} DESTINATION ${targetpath} RENAME ${icon})
+89c96
+< install(FILES mini-${icon} DESTINATION ${KDE1_MINIDIR}/${targetdir} RENAME ${icon})
+---
+> install(FILES mini-${icon} DESTINATION ${targetpath} RENAME ${icon})
+92c99
+< install(FILES large-${icon} DESTINATION ${KDE1_ICONDIR}/${targetdir}/large/ RENAME ${icon})
+---
+> install(FILES large-${icon} DESTINATION ${targetpath}/large/ RENAME ${icon})
+94a102,109
+>
+> function (install_icon icon targetdir)
+> install_icon_int("${icon}" "${targetdir}" FALSE)
+> endfunction ()
+>
+> function (install_icon_abs icon targetdir)
+> install_icon_int("${icon}" "${targetdir}" TRUE)
+> endfunction()
diff --git a/PKGBUILD b/PKGBUILD
index e39c65616760..cf471a1d5f16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=kde1-kdelibs
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Historical copy of the libraries module of KDE 1, adapted to compile on modern systems (circa. 2016)"
arch=('i686' 'x86_64')
url="https://github.com/KDE/kde1-kdelibs"
@@ -11,8 +11,15 @@ groups=("kde1")
depends=("qt1" "libpng" "libjpeg-turbo" "libtiff")
makedepends=("cmake")
_commit="98b923b0a56423c6de5c5f2f68f457249b3e3cf6"
-source=("https://github.com/KDE/$pkgname/archive/$_commit.zip")
-sha256sums=('be19075ccddb1141267cc445a3025ebb4654d0dc4e928580c571f16c699c59a6')
+source=("https://github.com/KDE/$pkgname/archive/$_commit.zip"
+ "KDE1Macros.patch")
+sha256sums=('be19075ccddb1141267cc445a3025ebb4654d0dc4e928580c571f16c699c59a6'
+ 'd7adbb94ba65fc0d37c5e8ad4975a2c550562dae9131ff23086507a17d4cdba9')
+
+prepare() {
+ cd $srcdir/$pkgname-$_commit
+ patch -p1 cmake/KDE1Macros.cmake < $srcdir/KDE1Macros.patch
+}
build() {
cd $srcdir/$pkgname-$_commit