summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-09-27 14:50:39 +0200
committerMartin T. H. Sandsmark2020-09-27 14:50:39 +0200
commit73caa67b8c5b7b4aac1b03ff6d9e9d05e9089d70 (patch)
tree268050ab1b357f9909c10a2f14bc35711d113351
downloadaur-73caa67b8c5b7b4aac1b03ff6d9e9d05e9089d70.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0a608283c0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kde1-kdenetwork-git
+ pkgdesc = Historical copy of the network module of KDE 1, adapted to compile on modern systems
+ pkgver = 1.1.2r2979.157d50dd
+ pkgrel = 1
+ url = https://quickgit.kde.org/?p=kde1-kdenetwork.git
+ arch = i686
+ arch = x86_64
+ groups = kde1
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ depends = kde1-kdelibs
+ provides = kde1-kdenetwork
+ conflicts = kde1-kdenetwork
+ source = git+https://github.com/KDE/kde1-kdenetwork.git
+ md5sums = SKIP
+
+pkgname = kde1-kdenetwork-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35d94943faba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Martin
+
+_module=network
+pkgname=kde1-kde${_module}-git
+pkgver=1.1.2r2979.157d50dd
+pkgrel=1
+pkgdesc="Historical copy of the $_module module of KDE 1, adapted to compile on modern systems"
+arch=(i686 x86_64)
+url="https://quickgit.kde.org/?p=kde1-kde${_module}.git"
+license=("GPL2")
+groups=(kde1)
+depends=(kde1-kdelibs)
+makedepends=(cmake git)
+provides=(kde1-kde${_module})
+conflicts=(kde1-kde${_module})
+
+# Mirror
+source=("git+https://github.com/KDE/kde1-kde${_module}.git")
+#source=("git+https://anongit.kde.org/kde1-kde${_module}.git")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd kde1-kde${_module}
+ printf "1.1.2r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build && mkdir build
+ else
+ mkdir build
+ fi
+}
+
+build() {
+ cd build
+ cmake "$srcdir"/kde1-kde${_module} -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir"/kde1-kde${_module}
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}