summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-01-06 00:43:51 +0100
committerMartin T. H. Sandsmark2021-01-06 00:43:51 +0100
commit24901ca7779ab978adf4ddb540363133ae9b4f7b (patch)
treeded2d9854403f3b566e7149c1bf4f8e09f847a5c
downloadaur-24901ca7779ab978adf4ddb540363133ae9b4f7b.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94966ccf0c18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kde2-kdeartwork-git
+ pkgdesc = Historical copy of the artwork module of KDE 2, adapted to compile on modern systems
+ pkgver = 2.2.2.r8.ce8351f
+ pkgrel = 1
+ url = https://github.com/sandsmark/kdeartwork
+ arch = i686
+ arch = x86_64
+ groups = kde2
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ depends = kde2-kdelibs
+ provides = kde2-kdeartwork
+ conflicts = kde2-kdeartwork
+ options = libtool
+ source = git+https://github.com/sandsmark/kde2-kdeartwork.git
+ md5sums = SKIP
+
+pkgname = kde2-kdeartwork-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6ab1bc729d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Martin
+
+_module=artwork
+pkgname=kde2-kde${_module}-git
+pkgver=2.2.2.r8.ce8351f
+pkgrel=1
+pkgdesc="Historical copy of the $_module module of KDE 2, adapted to compile on modern systems"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/kde${_module}"
+license=("GPL2")
+groups=(kde2)
+depends=(qt2-git audiofile python libtool libxslt hicolor-icon-theme)
+makedepends=(cmake git)
+optdepends=('java: java support')
+provides=(kde2-kde${_module})
+conflicts=(kde2-kde${_module})
+options=(libtool)
+
+# Mirror
+source=("git+https://github.com/sandsmark/kde2-kde${_module}.git")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd kde2-kde${_module}
+ printf "2.2.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build && mkdir build
+ else
+ mkdir build
+ fi
+
+ cd kde2-kde${_module}
+}
+
+build() {
+ cd build
+ cmake "$srcdir"/kde2-kde${_module} -DCMAKE_INSTALL_PREFIX=/usr -DKDEDIR=/usr/
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir/" install
+}