summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-01-06 00:48:06 +0100
committerMartin T. H. Sandsmark2021-01-06 00:48:06 +0100
commita6b3de5d69969ce8787bb9774a0d5826a0dc7a0b (patch)
tree8eed2044ce896d9e0dfebf3487f21bc06e04baff
downloadaur-a6b3de5d69969ce8787bb9774a0d5826a0dc7a0b.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55108e854074
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kde2-kdegraphics-git
+ pkgdesc = Historical copy of the graphics module of KDE 2, adapted to compile on modern systems
+ pkgver = 2.2.2.r7.d4eb496
+ pkgrel = 1
+ url = https://github.com/sandsmark/kdegraphics
+ arch = i686
+ arch = x86_64
+ groups = kde2
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ depends = kde2-kdelibs
+ provides = kde2-kdegraphics
+ conflicts = kde2-kdegraphics
+ conflicts = kcolorchooser
+ conflicts = kruler
+ options = libtool
+ source = git+https://github.com/sandsmark/kde2-kdegraphics.git
+ md5sums = SKIP
+
+pkgname = kde2-kdegraphics-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..179a7e158e03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Martin
+
+_module=graphics
+pkgname=kde2-kde${_module}-git
+pkgver=2.2.2.r7.d4eb496
+pkgrel=1
+pkgdesc="Historical copy of the $_module module of KDE 2, adapted to compile on modern systems"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/kde${_module}"
+license=("GPL2")
+groups=(kde2)
+depends=(kde2-kdelibs)
+makedepends=(cmake git)
+provides=(kde2-kde${_module})
+conflicts=(kde2-kde${_module} kcolorchooser kruler)
+options=(libtool)
+
+# Mirror
+source=("git+https://github.com/sandsmark/kde2-kde${_module}.git")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd kde2-kde${_module}
+ printf "2.2.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build && mkdir build
+ else
+ mkdir build
+ fi
+
+ cd kde2-kde${_module}
+}
+
+build() {
+ cd build
+ cmake "$srcdir"/kde2-kde${_module} -DCMAKE_INSTALL_PREFIX=/usr -DKDEDIR=/usr/
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir"/kde2-kde${_module}
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}