summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-04-08 15:15:40 +0200
committerMartin T. H. Sandsmark2021-04-08 15:15:40 +0200
commitdcad27ba241bf57c769fedeb9b74425ea450596b (patch)
tree03fdb4ecdae9d9b074e76bec3ccb0dc45df1d384
downloadaur-dcad27ba241bf57c769fedeb9b74425ea450596b.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..820532aaa1b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kde2-kdetoys-git
+ pkgdesc = Historical copy of the toys module of KDE 2, adapted to compile on modern systems
+ pkgver = 2.2.2.r5.c2a4af8
+ pkgrel = 1
+ url = https://invent.kde.org/sandsmark/kde2-kdetoys
+ arch = i686
+ arch = x86_64
+ groups = kde2
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ depends = kde2-kdelibs
+ depends = qt2-git
+ provides = kde2-kdetoys
+ conflicts = kde2-kdetoys
+ options = libtool
+ source = git+https://invent.kde.org/sandsmark/kde2-kdetoys.git
+ md5sums = SKIP
+
+pkgname = kde2-kdetoys-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2710943d5483
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Martin
+
+_module=toys
+pkgname=kde2-kde${_module}-git
+pkgver=2.2.2.r5.c2a4af8
+pkgrel=1
+pkgdesc="Historical copy of the $_module module of KDE 2, adapted to compile on modern systems"
+arch=(i686 x86_64)
+url="https://invent.kde.org/sandsmark/kde2-kde${_module}"
+license=("GPL2")
+groups=(kde2)
+depends=(kde2-kdelibs qt2-git)
+makedepends=(cmake git)
+provides=(kde2-kde${_module})
+conflicts=(kde2-kde${_module})
+options+=(libtool)
+
+source=("git+https://invent.kde.org/sandsmark/kde2-kde${_module}.git")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd kde2-kde${_module}
+ printf "2.2.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build && mkdir build
+ else
+ mkdir build
+ fi
+}
+
+build() {
+ cd build
+ cmake "$srcdir"/kde2-kde${_module} -DCMAKE_INSTALL_PREFIX=/usr -DKDEDIR=/usr/ -DCMAKE_BUILD_TYPE=Debug
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir"/kde2-kde${_module}
+}