summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2017-08-23 00:27:20 +0000
committerCharles Bos2017-08-23 00:27:20 +0000
commitd4db5531d86fc7ab51d6808f59616f0eb475acd0 (patch)
tree8bcfe58c29472e2eb40bfaa85b7d18ee9fea61cf
parenta9b3cfce618929e4bd20a812e436d0eaed601a7a (diff)
downloadaur-d4db5531d86fc7ab51d6808f59616f0eb475acd0.tar.gz
Add deps kactivities4, strigi and qtwebkit. add -fpermissive to cxxflags. disable webbrowser applet and webkit scriptengine.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
-rw-r--r--no-webkit.patch27
3 files changed, 54 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c895f53a5b9d..400fe80a6891 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Dec 12 10:14:08 UTC 2015
+# Wed Aug 23 00:25:14 UTC 2017
pkgbase = kdebase-workspace
pkgdesc = Provides the interface and basic tools for the KDE workspace
pkgver = 4.11.22
- pkgrel = 4
+ pkgrel = 5
url = https://projects.kde.org/projects/kde/kde-workspace
install = kdebase-workspace.install
arch = i686
@@ -42,6 +42,9 @@ pkgbase = kdebase-workspace
depends = xcb-util-wm
depends = pciutils
depends = glu
+ depends = kactivities4
+ depends = strigi
+ depends = qtwebkit
optdepends = kde-wallpapers: wallpapers for KDE Plasma Workspaces
optdepends = appmenu-qt: menu applications over dbus
optdepends = kdepim4-runtime: to display events in the calendar
@@ -49,7 +52,7 @@ pkgbase = kdebase-workspace
backup = etc/pam.d/kde
backup = etc/pam.d/kde-np
backup = etc/pam.d/kscreensaver
- source = http://download.kde.org/stable/applications/15.08.0/src/kde-workspace-4.11.22.tar.xz
+ source = http://download.kde.org/Attic/applications/15.08.0/src/kde-workspace-4.11.22.tar.xz
source = kde.pam
source = kde-np.pam
source = kscreensaver.pam
@@ -60,6 +63,7 @@ pkgbase = kdebase-workspace
source = kdm-xinitrd.patch
source = khotkeys-qt4.patch
source = dbus-update-environment.patch
+ source = no-webkit.patch
sha1sums = f08fbe309ed16c51ad31b0b260b2adeb7af1bb37
sha1sums = 660eae40a707d2711d8d7f32a93214865506b795
sha1sums = 6aeecc9e0e221f0515c6bf544f9a3c11cb6961fe
@@ -71,6 +75,7 @@ pkgbase = kdebase-workspace
sha1sums = d509dac592bd8b310df27991b208c95b6d907514
sha1sums = aa9d2e5a69986c4c3d47829721ea99edb473be12
sha1sums = 410311314b1ccb1ed5607dcf8bd418074d8c4019
+ sha1sums = 9a9b4ed07da06b8f02ce0ba9bc1958ae89c8a926
pkgname = kdebase-workspace
diff --git a/PKGBUILD b/PKGBUILD
index c0e9fe959275..ea7e404b4302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# $Id: PKGBUILD 253960 2015-12-08 15:40:43Z allan $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Charles Bos <charlesbos1 AT gmail>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=kdebase-workspace
_pkgname=kde-workspace
pkgver=4.11.22
_pkgver=15.08.0
-pkgrel=4
+pkgrel=5
pkgdesc="Provides the interface and basic tools for the KDE workspace"
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/kde-workspace'
@@ -20,16 +20,18 @@ depends=('kdebase-runtime' 'kdepimlibs4' 'lm_sensors' 'libraw1394'
'libxklavier' 'xorg-xsetroot' 'libxcomposite' 'libxinerama'
'xorg-xrdb' 'libxres' 'xorg-xrandr' 'xorg-xmessage' 'libusb-compat'
'kde-base-artwork' 'xcb-util-renderutil' 'xcb-util-image' 'ttf-font'
- 'xcb-util-keysyms' 'xcb-util-wm' 'pciutils' 'glu')
+ 'xcb-util-keysyms' 'xcb-util-wm' 'pciutils' 'glu' 'kactivities4'
+ 'strigi' 'qtwebkit')
makedepends=('cmake' 'automoc4' 'boost' 'kdebindings-python2' 'networkmanager')
optdepends=('kde-wallpapers: wallpapers for KDE Plasma Workspaces'
'appmenu-qt: menu applications over dbus' 'kdepim4-runtime: to display events in the calendar')
install="${pkgname}.install"
backup=('usr/share/config/kdm/kdmrc' 'etc/pam.d/kde' 'etc/pam.d/kde-np' 'etc/pam.d/kscreensaver')
-source=("http://download.kde.org/stable/applications/${_pkgver}/src/${_pkgname}-${pkgver}.tar.xz"
+source=("http://download.kde.org/Attic/applications/${_pkgver}/src/${_pkgname}-${pkgver}.tar.xz"
'kde.pam' 'kde-np.pam' 'kscreensaver.pam' 'kdm.service' 'kdm.logrotate'
'etc-scripts.patch' 'terminate-server.patch' 'kdm-xinitrd.patch'
- 'khotkeys-qt4.patch' 'dbus-update-environment.patch')
+ 'khotkeys-qt4.patch' 'dbus-update-environment.patch'
+ 'no-webkit.patch')
sha1sums=('f08fbe309ed16c51ad31b0b260b2adeb7af1bb37'
'660eae40a707d2711d8d7f32a93214865506b795'
'6aeecc9e0e221f0515c6bf544f9a3c11cb6961fe'
@@ -40,10 +42,11 @@ sha1sums=('f08fbe309ed16c51ad31b0b260b2adeb7af1bb37'
'ac7bc292c865bc1ab8c02e6341aa7aeaf1a3eeee'
'd509dac592bd8b310df27991b208c95b6d907514'
'aa9d2e5a69986c4c3d47829721ea99edb473be12'
- '410311314b1ccb1ed5607dcf8bd418074d8c4019')
+ '410311314b1ccb1ed5607dcf8bd418074d8c4019'
+ '9a9b4ed07da06b8f02ce0ba9bc1958ae89c8a926')
prepare() {
- mkdir build
+ if [ ! -d build ]; then mkdir build; fi
cd ${_pkgname}-${pkgver}
@@ -58,6 +61,11 @@ prepare() {
# KDEBUG#202629
patch -p0 -i "${srcdir}"/terminate-server.patch
+
+ # Disable compilation of some webkit-related components.
+ # We cannot build these anymore as kdelibs in arch no
+ # longer provides kdewebkit
+ patch -p1 -i "${srcdir}/no-webkit.patch"
}
build() {
@@ -72,7 +80,8 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DWITH_CkConnector=OFF \
-DWITH_NepomukCore=OFF \
- -DWITH_Soprano=OFF
+ -DWITH_Soprano=OFF \
+ -DCMAKE_CXX_FLAGS="-fpermissive"
make
}
diff --git a/no-webkit.patch b/no-webkit.patch
new file mode 100644
index 000000000000..f70be58fabf6
--- /dev/null
+++ b/no-webkit.patch
@@ -0,0 +1,27 @@
+diff -Nur original/plasma/generic/applets/CMakeLists.txt modified/plasma/generic/applets/CMakeLists.txt
+--- original/plasma/generic/applets/CMakeLists.txt 2015-08-12 07:03:15.000000000 +0000
++++ modified/plasma/generic/applets/CMakeLists.txt 2017-08-22 23:38:59.880383160 +0000
+@@ -12,10 +12,6 @@
+ add_subdirectory(digital-clock)
+ add_subdirectory(quicklaunch)
+
+-if(QT_QTWEBKIT_FOUND)
+- add_subdirectory(webbrowser)
+-endif(QT_QTWEBKIT_FOUND)
+-
+ if(NOT WIN32)
+ add_subdirectory(system-monitor)
+ #notifications
+diff -Nur original/plasma/generic/scriptengines/CMakeLists.txt modified/plasma/generic/scriptengines/CMakeLists.txt
+--- original/plasma/generic/scriptengines/CMakeLists.txt 2015-08-12 07:03:15.000000000 +0000
++++ modified/plasma/generic/scriptengines/CMakeLists.txt 2017-08-22 23:57:04.857049819 +0000
+@@ -1,9 +1,5 @@
+ macro_optional_add_subdirectory(ruby)
+
+-if(QT_QTWEBKIT_FOUND)
+- macro_optional_add_subdirectory(webkit)
+-endif(QT_QTWEBKIT_FOUND)
+-
+ if (PYTHONLIBRARY_FOUND AND NOT WIN32)
+ macro_optional_add_subdirectory(python)
+ endif (PYTHONLIBRARY_FOUND AND NOT WIN32)