summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Roux2020-02-17 20:33:53 +0100
committerMathias Roux2020-02-17 20:33:53 +0100
commit438a46c22219f29f84861ada38f731d91fd06555 (patch)
tree2903fa3201560b62de911ee4d94cd6466061f662
downloadaur-438a46c22219f29f84861ada38f731d91fd06555.tar.gz
First commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD33
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faa0867ebea3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = kdeconnect-bluetooth
+ pkgdesc = Adds communication between KDE and your smartphone, with a bluetooth backend
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://community.kde.org/KDEConnect
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ depends = hicolor-icon-theme
+ depends = kcmutils
+ depends = kwayland
+ depends = libfakekey
+ depends = qca
+ depends = kpeoplevcard
+ depends = pulseaudio-qt
+ depends = kirigami2
+ optdepends = sshfs: remote filesystem browser
+ optdepends = python-nautilus: Nautilus integration
+ provides = kdeconnect
+ source = https://download.kde.org/stable/kdeconnect-bluetooth/1.4/kdeconnect-bluetooth-kde-1.4.tar.xz
+ source = https://download.kde.org/stable/kdeconnect-bluetooth/1.4/kdeconnect-bluetooth-kde-1.4.tar.xz.sig
+ sha256sums = caee7945a9d9bb881a943dc8d2fd0d702c04da5bdb2df14d4f875e7cf5d5261a
+ sha256sums = SKIP
+
+pkgname = kdeconnect-bluetooth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..540e2c547d75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Mathias Roux <poussinberlin@gmail.com>
+#Based on the official kdeconnect PKGBUILD
+pkgname=kdeconnect-bluetooth
+pkgver=1.4
+pkgrel=1
+pkgdesc='Adds communication between KDE and your smartphone, with a bluetooth backend'
+url='https://community.kde.org/KDEConnect'
+license=(GPL)
+arch=(x86_64)
+depends=(hicolor-icon-theme kcmutils kwayland libfakekey qca kpeoplevcard pulseaudio-qt kirigami2)
+makedepends=(extra-cmake-modules kdoctools)
+optdepends=('sshfs: remote filesystem browser' 'python-nautilus: Nautilus integration')
+provides=('kdeconnect')
+source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-kde-$pkgver.tar.xz"{,.sig})
+sha256sums=('caee7945a9d9bb881a943dc8d2fd0d702c04da5bdb2df14d4f875e7cf5d5261a'
+ 'SKIP')
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-kde-$pkgver \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib\
+ -DBLUETOOTH_ENABLED=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}