summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRihards Skuja2019-11-25 00:05:19 +0200
committerRihards Skuja2019-11-25 00:05:19 +0200
commitbd2beaf68de775fddcdaea96983a8ff94119aee8 (patch)
tree9026d17cffdb3b541adeee428899f179e9294185
parentf33246e41f7b074ab30a3f489db79c992d3b4ad9 (diff)
downloadaur-bd2beaf68de775fddcdaea96983a8ff94119aee8.tar.gz
clean up PKGBUILD and fix missing dependencies
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
-rw-r--r--kdeconnect-git.install12
4 files changed, 39 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77be5f2b384f..60e3834860d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,29 @@
pkgbase = kdeconnect-git
pkgdesc = Adds communication between KDE and your smartphone
- pkgver = r1108.9494081
+ pkgver = 1.3.3.r812.4a6a98d8
pkgrel = 1
url = https://community.kde.org/KDEConnect
- install = kdeconnect-git.install
- arch = i686
arch = x86_64
license = GPL2
- makedepends = extra-cmake-modules
makedepends = git
- makedepends = python
- depends = kio
- depends = kde-cli-tools
- depends = qca-qt5
- depends = libfakekey
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = qt5-declarative
depends = hicolor-icon-theme
+ depends = kcmutils
depends = kwayland
+ depends = libfakekey
+ depends = qca
+ depends = kpeople
+ depends = kpeople-vcard-git
+ depends = kirigami2
+ depends = pulseaudio-qt
optdepends = sshfs: remote filesystem browser
+ optdepends = kde-cli-tools: configuration UI
+ optdepends = python-nautilus: Nautilus integration
provides = kdeconnect
- conflicts = kdeconnect-frameworks
conflicts = kdeconnect
- source = git://anongit.kde.org/kdeconnect-kde.git
+ source = git+https://invent.kde.org/kde/kdeconnect-kde.git
sha256sums = SKIP
pkgname = kdeconnect-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 34580909309f..4049e342d0c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Maintainer: Vojtech Kral <vojtech_kral^hk>
+# Maintainer: Rihards Skuja <rhssk at posteo dot eu>
+# Contributor: Vojtech Kral <vojtech_kral^hk>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Kuba Serafinowski <zizzfizzix(at)gmail(dot)com>
-pkgname=kdeconnect-git
-pkgver=r1108.9494081
+_remotename=kdeconnect-kde
+_pkgname=kdeconnect
+pkgname=$_pkgname-git
+pkgver=1.3.3.r812.4a6a98d8
pkgrel=1
pkgdesc='Adds communication between KDE and your smartphone'
-arch=(i686 x86_64)
+arch=(x86_64)
url='https://community.kde.org/KDEConnect'
license=(GPL2)
-depends=(kio kde-cli-tools qca-qt5 libfakekey hicolor-icon-theme kwayland) # telepathy-qt5 - requires 0.9.7
-makedepends=(extra-cmake-modules git python)
-optdepends=('sshfs: remote filesystem browser')
-provides=(kdeconnect)
-conflicts=(kdeconnect-frameworks kdeconnect)
-source=("git://anongit.kde.org/kdeconnect-kde.git")
-install=$pkgname.install
+depends=(hicolor-icon-theme kcmutils kwayland libfakekey qca kpeople
+ kpeople-vcard-git kirigami2 pulseaudio-qt)
+makedepends=(git extra-cmake-modules kdoctools qt5-declarative)
+optdepends=('sshfs: remote filesystem browser'
+ 'kde-cli-tools: configuration UI'
+ 'python-nautilus: Nautilus integration')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("git+https://invent.kde.org/kde/$_remotename.git")
sha256sums=('SKIP')
pkgver() {
- cd kdeconnect-kde
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_remotename
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
@@ -29,12 +34,9 @@ prepare() {
build() {
cd build
- cmake ../kdeconnect-kde \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DLIB_INSTALL_DIR=lib \
- -DLIBEXEC_INSTALL_DIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cmake ../$_remotename \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF
make
}
diff --git a/kdeconnect-git.install b/kdeconnect-git.install
deleted file mode 100644
index 5495fb1b5d27..000000000000
--- a/kdeconnect-git.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}