summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 23:01:44 +0200
committerAntonio Rojas2015-06-08 23:01:44 +0200
commitdb001a3453185bbddc01a4de57335d0bb879af9b (patch)
tree136fc5b995ad67986dcec44bb181cb61262d23f3
downloadaur-db001a3453185bbddc01a4de57335d0bb879af9b.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
-rw-r--r--kdeconnect-git.install12
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ecd83a50570
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = kdeconnect-git
+ pkgdesc = Adds communication between KDE and your smartphone
+ pkgver = r804.e34a291
+ pkgrel = 1
+ url = https://projects.kde.org/projects/playground/base/kdeconnect-kde
+ install = kdeconnect-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = python
+ depends = kio
+ depends = kcmutils
+ depends = qca-qt5
+ depends = libfakekey
+ depends = hicolor-icon-theme
+ provides = kdeconnect
+ conflicts = kdeconnect-frameworks
+ conflicts = kdeconnect
+ replaces = kdeconnect-frameworks-git
+ source = git://anongit.kde.org/kdeconnect-kde.git
+ sha256sums = SKIP
+
+pkgname = kdeconnect-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..725e46af6b89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Kuba Serafinowski <zizzfizzix(at)gmail(dot)com>
+
+pkgname=kdeconnect-git
+pkgver=r804.e34a291
+pkgrel=1
+pkgdesc='Adds communication between KDE and your smartphone'
+arch=(i686 x86_64)
+url='https://projects.kde.org/projects/playground/base/kdeconnect-kde'
+license=(GPL2)
+depends=(kio kcmutils qca-qt5 libfakekey hicolor-icon-theme)
+makedepends=(extra-cmake-modules git python)
+provides=(kdeconnect)
+conflicts=(kdeconnect-frameworks kdeconnect)
+replaces=(kdeconnect-frameworks-git)
+source=("git://anongit.kde.org/kdeconnect-kde.git")
+install=$pkgname.install
+sha256sums=('SKIP')
+
+pkgver() {
+ cd kdeconnect-kde
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kdeconnect-kde \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DLIBEXEC_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/kdeconnect-git.install b/kdeconnect-git.install
new file mode 100644
index 000000000000..5495fb1b5d27
--- /dev/null
+++ b/kdeconnect-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}