summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 09:00:29 -0700
committerJonathan Yantis2015-06-11 09:00:29 -0700
commit7c343d3efa1e644a6b51f03844eb94dc16b22647 (patch)
tree39010c4b9ded86adc6a7bae7883dbbb63da3d055
downloadaur-7c343d3efa1e644a6b51f03844eb94dc16b22647.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--kmix.install11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4b5c97f1a24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = kdemultimedia-kmix-git
+ pkgdesc = KDE volume control program. KMix. KDE's full featured mini mixer
+ pkgver = 4.6RC1.r1978.f911772
+ pkgrel = 2
+ epoch = 1
+ url = http://www.kde.org/applications/multimedia/kmix/
+ install = kmix.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = FDL
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = git
+ makedepends = docbook-xsl
+ depends = kdebase-runtime
+ provides = kdemultimedia-kmix
+ conflicts = kdemultimedia-kmix
+ source = kmix::git://anongit.kde.org/kmix
+ md5sums = SKIP
+
+pkgname = kdemultimedia-kmix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34f57df7329c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : jyantis <yantis@yantis.net>
+# Contributor: Zom <zom[at]eevul[dot]org>
+# Contributor: (archdria) Adria Arrufat <swiftscythe (at) gmail.com>
+
+pkgname=kdemultimedia-kmix-git
+pkgver=4.6RC1.r1978.f911772
+pkgrel=2
+pkgdesc="KDE volume control program. KMix. KDE's full featured mini mixer"
+arch=('i686' 'x86_64')
+url="http://www.kde.org/applications/multimedia/kmix/"
+license=('GPL' 'FDL')
+depends=('kdebase-runtime')
+makedepends=('cmake' 'automoc4' 'git' 'docbook-xsl')
+provides=("kdemultimedia-kmix")
+conflicts=("kdemultimedia-kmix")
+source=("kmix::git://anongit.kde.org/kmix")
+md5sums=('SKIP')
+install=kmix.install
+epoch=1
+
+pkgver() {
+ cd kmix
+ _version=$(grep -F "#define APP_VERSION" core/version.h | awk -F\" '{print $2}')
+ printf "%s." "$_version"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd kmix
+ cmake . -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd kmix
+ make DESTDIR=${pkgdir} install
+}
diff --git a/kmix.install b/kmix.install
new file mode 100644
index 000000000000..c0797237a025
--- /dev/null
+++ b/kmix.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}