summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2015-08-03 15:44:41 +0200
committerevorster2015-08-03 15:44:41 +0200
commitad5a2abdd338058c06d7622f3ae116a602eb082f (patch)
treef022ee62b5a0ace1b654c4ec3480fab2d946780f
downloadaur-ad5a2abdd338058c06d7622f3ae116a602eb082f.tar.gz
Package imported by apac-migrate
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD53
-rw-r--r--kdenlive-git.install13
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98607002e8bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = kdenlive-git
+ pkgdesc = A non-linear video editor for Linux using the MLT video framework. KF5 Frameworks (GIT Version)
+ pkgver = 15.04.0.r5768.66e7120
+ pkgrel = 1
+ url = http://http://www.kdenlive.org/
+ install = kdenlive-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = git
+ makedepends = v4l-utils
+ depends = glu
+ depends = knewstuff
+ depends = kplotting
+ depends = knotifyconfig
+ depends = mlt
+ depends = hicolor-icon-theme
+ optdepends = ffmpeg: for FFmpeg plugin
+ optdepends = cdrkit: for creation of DVD ISO images
+ optdepends = dvdauthor: for creation of DVD
+ optdepends = dvgrab: for firewire capture
+ optdepends = libdv: for webcam capture (if FFmpeg is not installed)
+ optdepends = recordmydesktop: for screen capture
+ optdepends = xine-ui: for DVD preview
+ provides = kdenlive
+ conflicts = kdenlive
+ source = git://anongit.kde.org/kdenlive
+ sha1sums = SKIP
+
+pkgname = kdenlive-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d22d5dc8a3dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Evert Vorster <evorster@gmail.com>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: IncredibleLaser
+# Contributor: nous <nous at archlinux.us>
+# Contributor: pressh
+
+pkgname=kdenlive-git
+pkgver=15.04.0.r5768.66e7120
+pkgrel=1
+pkgdesc="A non-linear video editor for Linux using the MLT video framework. KF5 Frameworks (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://http://www.kdenlive.org/"
+license=('GPL')
+depends=('glu' 'knewstuff' 'kplotting' 'knotifyconfig' 'mlt' 'hicolor-icon-theme')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'v4l-utils')
+optdepends=('ffmpeg: for FFmpeg plugin'
+ 'cdrkit: for creation of DVD ISO images'
+ 'dvdauthor: for creation of DVD'
+ 'dvgrab: for firewire capture'
+ 'libdv: for webcam capture (if FFmpeg is not installed)'
+ 'recordmydesktop: for screen capture'
+ 'xine-ui: for DVD preview')
+provides=('kdenlive')
+conflicts=('kdenlive')
+source=('git://anongit.kde.org/kdenlive')
+sha1sums=('SKIP')
+install=$pkgname.install
+
+pkgver() {
+ cd kdenlive
+ _ver="$(cat CMakeLists.txt | grep KDENLIVE_VERSION | head -n1 | cut -d ' ' -f2 | tr -d ')')"
+ echo "$(echo ${_ver}).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kdenlive \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
+
diff --git a/kdenlive-git.install b/kdenlive-git.install
new file mode 100644
index 000000000000..9aef867f9d21
--- /dev/null
+++ b/kdenlive-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-mime-database usr/share/mime &>/dev/null
+ update-desktop-database -q &>/dev/null
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}