summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2018-02-26 17:23:16 +0000
committerCharles Bos2018-02-26 17:23:16 +0000
commit961dfc4efc1c064c360e6ded41424c312cfd29a4 (patch)
treee372e15d487058a2408cd36a7b1c389227c53836
parent50337ab7c66e99748d8a67c1248ed9d64f9d31ae (diff)
downloadaur-961dfc4efc1c064c360e6ded41424c312cfd29a4.tar.gz
Add patch for building against libical 3. switch dependency on libical2 to libical. switch make dependency on akonadi-qt4 to akonadi
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--fix-build-with-ical-3.0.diff188
3 files changed, 207 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9917617b1516..d1736f13e845 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kdepimlibs4
pkgdesc = KDE4 PIM Libraries
pkgver = 4.14.10
- pkgrel = 12
+ pkgrel = 13
url = https://projects.kde.org/projects/kde/kdepimlibs
arch = x86_64
license = GPL
@@ -10,10 +10,10 @@ pkgbase = kdepimlibs4
makedepends = automoc4
makedepends = boost
makedepends = cyrus-sasl
- makedepends = akonadi-qt4
+ makedepends = akonadi
depends = kdelibs
depends = libakonadi-qt4
- depends = libical2
+ depends = libical
depends = qjson
provides = kdepimlibs
conflicts = kdepimlibs
@@ -21,9 +21,11 @@ pkgbase = kdepimlibs4
source = https://download.kde.org/Attic/applications/15.04.3/src/kdepimlibs-4.14.10.tar.xz
source = kdepimlibs4-bug338658-1.patch::https://cgit.kde.org/kdepimlibs.git/patch/?id=4429619
source = kdepimlibs4-bug338658-2.patch::https://cgit.kde.org/kdepimlibs.git/patch/?id=d8b5da7
+ source = fix-build-with-ical-3.0.diff
sha1sums = 8db2f59b8a33f4d1bbebfdff8b772d30669c9932
sha1sums = 8bebf347baf5a8058b5abac42a5bb417540ade1a
sha1sums = cf33e0350b0384b6bc640ebc1c65fa10650b35ce
+ sha1sums = 33604606832f4489390bdbc0f94ea51bb791fc4b
pkgname = kdepimlibs4
diff --git a/PKGBUILD b/PKGBUILD
index 51ffcccdb68d..269c8cc44618 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# $Id$
-# Contributor: Charles Bos <charlesbos1 AT gmail>
+# Maintainer: Charles Bos <charlesbos1 AT gmail>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
@@ -7,22 +6,26 @@
pkgname=kdepimlibs4
pkgver=4.14.10
_kdeappver=15.04.3
-pkgrel=12
+pkgrel=13
pkgdesc="KDE4 PIM Libraries"
arch=('x86_64')
url='https://projects.kde.org/projects/kde/kdepimlibs'
license=('GPL' 'LGPL')
-depends=('kdelibs' 'libakonadi-qt4' 'libical2' 'qjson')
-makedepends=('cmake' 'automoc4' 'boost' 'cyrus-sasl' 'akonadi-qt4')
+depends=('kdelibs' 'libakonadi-qt4' 'libical' 'qjson')
+# Note: makedepend on akonadi (KDE5 version) is not a mistake
+# akonadi-qt4 is not needed here
+makedepends=('cmake' 'automoc4' 'boost' 'cyrus-sasl' 'akonadi')
conflicts=('kdepimlibs')
provides=('kdepimlibs')
replaces=('kdepimlibs')
source=("https://download.kde.org/Attic/applications/${_kdeappver}/src/kdepimlibs-${pkgver}.tar.xz"
kdepimlibs4-bug338658-1.patch::"https://cgit.kde.org/kdepimlibs.git/patch/?id=4429619"
- kdepimlibs4-bug338658-2.patch::"https://cgit.kde.org/kdepimlibs.git/patch/?id=d8b5da7")
+ kdepimlibs4-bug338658-2.patch::"https://cgit.kde.org/kdepimlibs.git/patch/?id=d8b5da7"
+ fix-build-with-ical-3.0.diff)
sha1sums=('8db2f59b8a33f4d1bbebfdff8b772d30669c9932'
'8bebf347baf5a8058b5abac42a5bb417540ade1a'
- 'cf33e0350b0384b6bc640ebc1c65fa10650b35ce')
+ 'cf33e0350b0384b6bc640ebc1c65fa10650b35ce'
+ '33604606832f4489390bdbc0f94ea51bb791fc4b')
prepare() {
mkdir -p build
@@ -34,6 +37,10 @@ prepare() {
# Don't build gpgme++
sed -e '/gpgme++/d' -e '/qgpgme/d' -i CMakeLists.txt
+
+# Allow for building against libical 3
+# With thanks to the Fedora maintainers
+ patch -p1 -i ../fix-build-with-ical-3.0.diff
}
build() {
diff --git a/fix-build-with-ical-3.0.diff b/fix-build-with-ical-3.0.diff
new file mode 100644
index 000000000000..98755f6b918b
--- /dev/null
+++ b/fix-build-with-ical-3.0.diff
@@ -0,0 +1,188 @@
+diff -up kdepimlibs-4.14.10/kcalcore/icalformat_p.cpp.libical-3.0 kdepimlibs-4.14.10/kcalcore/icalformat_p.cpp
+--- kdepimlibs-4.14.10/kcalcore/icalformat_p.cpp.libical-3.0 2017-11-12 14:10:59.070922105 +0100
++++ kdepimlibs-4.14.10/kcalcore/icalformat_p.cpp 2017-11-12 14:11:16.499921863 +0100
+@@ -2301,7 +2301,6 @@ icaltimetype ICalFormatImpl::writeICalDa
+ t.second = 0;
+
+ t.is_date = 1;
+- t.is_utc = 0;
+ t.zone = 0;
+
+ return t;
+@@ -2322,8 +2321,7 @@ icaltimetype ICalFormatImpl::writeICalDa
+ t.minute = datetime.time().minute();
+ t.second = datetime.time().second();
+ }
+- t.zone = 0; // zone is NOT set
+- t.is_utc = datetime.isUtc() ? 1 : 0;
++ t.zone = datetime.isUtc() ? icaltimezone_get_utc_timezone() : 0; // zone is NOT set
+
+ // _dumpIcaltime( t );
+
+@@ -2398,7 +2396,7 @@ icalproperty *ICalFormatImpl::writeICalD
+ }
+
+ KTimeZone ktz;
+- if (!t.is_utc) {
++ if (!icaltime_is_utc( t )) {
+ ktz = dt.timeZone();
+ }
+
+@@ -2431,7 +2429,7 @@ KDateTime ICalFormatImpl::readICalDateTi
+ // _dumpIcaltime( t );
+
+ KDateTime::Spec timeSpec;
+- if (t.is_utc || t.zone == icaltimezone_get_utc_timezone()) {
++ if (icaltime_is_utc( t ) || t.zone == icaltimezone_get_utc_timezone()) {
+ timeSpec = KDateTime::UTC; // the time zone is UTC
+ utc = false; // no need to convert to UTC
+ } else {
+diff -up kdepimlibs-4.14.10/kcalcore/icaltimezones.cpp.libical-3.0 kdepimlibs-4.14.10/kcalcore/icaltimezones.cpp
+--- kdepimlibs-4.14.10/kcalcore/icaltimezones.cpp.libical-3.0 2017-11-12 14:11:03.603922042 +0100
++++ kdepimlibs-4.14.10/kcalcore/icaltimezones.cpp 2017-11-12 14:11:15.029921884 +0100
+@@ -54,7 +54,7 @@ static QDateTime toQDateTime(const icalt
+ {
+ return QDateTime(QDate(t.year, t.month, t.day),
+ QTime(t.hour, t.minute, t.second),
+- (t.is_utc ? Qt::UTC : Qt::LocalTime));
++ (icaltime_is_utc( t ) ? Qt::UTC : Qt::LocalTime));
+ }
+
+ // Maximum date for time zone data.
+@@ -81,7 +81,6 @@ static icaltimetype writeLocalICalDateTi
+ t.second = local.time().second();
+ t.is_date = 0;
+ t.zone = 0;
+- t.is_utc = 0;
+ return t;
+ }
+
+@@ -886,7 +885,7 @@ ICalTimeZone ICalTimeZoneSource::parse(i
+ case ICAL_LASTMODIFIED_PROPERTY:
+ {
+ const icaltimetype t = icalproperty_get_lastmodified(p);
+- if (t.is_utc) {
++ if (icaltime_is_utc( t )) {
+ data->d->lastModified = toQDateTime(t);
+ } else {
+ kDebug() << "LAST-MODIFIED not UTC";
+@@ -1259,7 +1258,7 @@ QList<QDateTime> ICalTimeZoneSourcePriva
+ // Convert DTSTART to QDateTime, and from local time to UTC
+ const QDateTime localStart = toQDateTime(dtstart); // local time
+ dtstart.second -= prevOffset;
+- dtstart.is_utc = 1;
++ dtstart.zone = icaltimezone_get_utc_timezone();
+ const QDateTime utcStart = toQDateTime(icaltime_normalize(dtstart)); // UTC
+
+ transitions += utcStart;
+@@ -1286,13 +1285,13 @@ QList<QDateTime> ICalTimeZoneSourcePriva
+ t.minute = dtstart.minute;
+ t.second = dtstart.second;
+ t.is_date = 0;
+- t.is_utc = 0; // dtstart is in local time
++ t.zone = 0; // dtstart is in local time
+ }
+ // RFC2445 states that RDATE must be in local time,
+ // but we support UTC as well to be safe.
+- if (!t.is_utc) {
++ if (!icaltime_is_utc( t )) {
+ t.second -= prevOffset; // convert to UTC
+- t.is_utc = 1;
++ t.zone = icaltimezone_get_utc_timezone();
+ t = icaltime_normalize(t);
+ }
+ transitions += toQDateTime(t);
+diff -up kdepimlibs-4.14.10/kcal/icalformat_p.cpp.libical-3.0 kdepimlibs-4.14.10/kcal/icalformat_p.cpp
+--- kdepimlibs-4.14.10/kcal/icalformat_p.cpp.libical-3.0 2017-11-12 14:10:50.692922220 +0100
++++ kdepimlibs-4.14.10/kcal/icalformat_p.cpp 2017-11-12 14:11:08.915921968 +0100
+@@ -2087,7 +2087,6 @@ icaltimetype ICalFormatImpl::writeICalDa
+ t.second = 0;
+
+ t.is_date = 1;
+- t.is_utc = 0;
+ t.zone = 0;
+
+ return t;
+@@ -2106,8 +2105,7 @@ icaltimetype ICalFormatImpl::writeICalDa
+ t.second = datetime.time().second();
+
+ t.is_date = 0;
+- t.zone = 0; // zone is NOT set
+- t.is_utc = datetime.isUtc() ? 1 : 0;
++ t.zone = datetime.isUtc() ? icaltimezone_get_utc_timezone() : 0;
+
+ // _dumpIcaltime( t );
+
+@@ -2174,7 +2172,7 @@ icalproperty *ICalFormatImpl::writeICalD
+ }
+
+ KTimeZone ktz;
+- if ( !t.is_utc ) {
++ if ( !icaltime_is_utc( t ) ) {
+ ktz = dt.timeZone();
+ }
+
+@@ -2207,7 +2205,7 @@ KDateTime ICalFormatImpl::readICalDateTi
+ // _dumpIcaltime( t );
+
+ KDateTime::Spec timeSpec;
+- if ( t.is_utc || t.zone == icaltimezone_get_utc_timezone() ) {
++ if ( icaltime_is_utc( t ) || t.zone == icaltimezone_get_utc_timezone() ) {
+ timeSpec = KDateTime::UTC; // the time zone is UTC
+ utc = false; // no need to convert to UTC
+ } else {
+diff -up kdepimlibs-4.14.10/kcal/icaltimezones.cpp.libical-3.0 kdepimlibs-4.14.10/kcal/icaltimezones.cpp
+--- kdepimlibs-4.14.10/kcal/icaltimezones.cpp.libical-3.0 2017-11-12 14:10:54.277922171 +0100
++++ kdepimlibs-4.14.10/kcal/icaltimezones.cpp 2017-11-12 14:11:13.407921906 +0100
+@@ -50,7 +50,7 @@ static QDateTime toQDateTime( const ical
+ {
+ return QDateTime( QDate( t.year, t.month, t.day ),
+ QTime( t.hour, t.minute, t.second ),
+- ( t.is_utc ? Qt::UTC : Qt::LocalTime ) );
++ ( icaltime_is_utc( t ) ? Qt::UTC : Qt::LocalTime ) );
+ }
+
+ // Maximum date for time zone data.
+@@ -77,7 +77,6 @@ static icaltimetype writeLocalICalDateTi
+ t.second = local.time().second();
+ t.is_date = 0;
+ t.zone = 0;
+- t.is_utc = 0;
+ return t;
+ }
+
+@@ -787,7 +786,7 @@ ICalTimeZone ICalTimeZoneSource::parse(
+ case ICAL_LASTMODIFIED_PROPERTY:
+ {
+ icaltimetype t = icalproperty_get_lastmodified(p);
+- if ( t.is_utc ) {
++ if ( icaltime_is_utc( t ) ) {
+ data->d->lastModified = toQDateTime( t );
+ } else {
+ kDebug() << "LAST-MODIFIED not UTC";
+@@ -972,7 +971,7 @@ QList<QDateTime> ICalTimeZoneSourcePriva
+ // Convert DTSTART to QDateTime, and from local time to UTC
+ QDateTime localStart = toQDateTime( dtstart ); // local time
+ dtstart.second -= prevOffset;
+- dtstart.is_utc = 1;
++ dtstart.zone = icaltimezone_get_utc_timezone();
+ QDateTime utcStart = toQDateTime( icaltime_normalize( dtstart ) ); // UTC
+
+ transitions += utcStart;
+@@ -999,13 +998,13 @@ QList<QDateTime> ICalTimeZoneSourcePriva
+ t.minute = dtstart.minute;
+ t.second = dtstart.second;
+ t.is_date = 0;
+- t.is_utc = 0; // dtstart is in local time
++ t.zone = 0; // dtstart is in local time
+ }
+ // RFC2445 states that RDATE must be in local time,
+ // but we support UTC as well to be safe.
+- if ( !t.is_utc ) {
++ if ( !icaltime_is_utc( t ) ) {
+ t.second -= prevOffset; // convert to UTC
+- t.is_utc = 1;
++ t.zone = icaltimezone_get_utc_timezone();
+ t = icaltime_normalize( t );
+ }
+ transitions += toQDateTime( t );