summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2020-09-30 13:09:30 +0200
committerIyán Méndez Veiga2020-09-30 13:09:30 +0200
commit14aec43c5d96ffe2505901a6c602d89f3afa566e (patch)
tree865c042c9cbb1e37254ac449a999b3d70c4bbf54
downloadaur-14aec43c5d96ffe2505901a6c602d89f3afa566e.tar.gz
Initial submit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd4244b30a2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kdeplasma-applets-fokus
+ pkgdesc = A simple pomodoro KDE plasmoid
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://gitlab.com/divinae/focus-plasmoid
+ arch = any
+ license = GPL
+ depends = plasma-workspace
+ source = https://gitlab.com/divinae/focus-plasmoid/-/archive/v1.4.0/focus-plasmoid-v1.4.0.tar.gz
+ sha512sums = fe96ad0cad80a9372280fe4fb59a47e1747f8c2531cbc7710202de6a34228332b39cd2bdff220e18e6193b76cf4a0c9366d3d91547fe241af8e6eb719d534851
+
+pkgname = kdeplasma-applets-fokus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..408f0bbd208d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+
+pkgname=kdeplasma-applets-fokus
+_gitpkgname=focus-plasmoid
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A simple pomodoro KDE plasmoid"
+arch=('any')
+url="https://gitlab.com/divinae/$_gitpkgname"
+license=('GPL')
+depends=('plasma-workspace')
+source=("https://gitlab.com/divinae/$_gitpkgname/-/archive/v$pkgver/$_gitpkgname-v$pkgver.tar.gz")
+sha512sums=('fe96ad0cad80a9372280fe4fb59a47e1747f8c2531cbc7710202de6a34228332b39cd2bdff220e18e6193b76cf4a0c9366d3d91547fe241af8e6eb719d534851')
+
+package() {
+ cd "$_gitpkgname-v$pkgver"
+ mkdir -p "$pkgdir/usr/share/plasma/plasmoids/fokus/"
+ cp -r package/* "$pkgdir/usr/share/plasma/plasmoids/fokus/"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}