summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Chen2015-06-07 18:30:08 +1200
committerAndrew Chen2015-06-07 19:36:13 +1200
commita83c6e1b07fd9eb4a864516e345b4464a0e9adac (patch)
treeb67dd719545db214685efcad839032c7c589ad42
downloadaur-a83c6e1b07fd9eb4a864516e345b4464a0e9adac.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--kdeplasma-applets-gmailfeed.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b2e99fe947d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kdeplasma-applets-gmailfeed
+ pkgdesc = A Plasma 5 plasmoid showing your Gmail feed.
+ pkgver = 1.1
+ pkgrel = 2
+ url = https://github.com/anthon38/gmailfeed
+ install = kdeplasma-applets-gmailfeed.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ depends = plasma-framework
+ depends = hicolor-icon-theme
+ depends = knotifications
+ source = https://github.com/anthon38/gmailfeed/archive/v1.1.tar.gz
+ md5sums = dce518313585f1e1c4da2cbdf0f8c676
+
+pkgname = kdeplasma-applets-gmailfeed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4f50ac78e15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andrew Chen <llkiwi2006@gmail.com>
+# Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=kdeplasma-applets-gmailfeed
+_pkgname=gmailfeed
+pkgver=1.1
+pkgrel=2
+pkgdesc="A Plasma 5 plasmoid showing your Gmail feed."
+arch=('i686' 'x86_64')
+url="https://github.com/anthon38/gmailfeed"
+license=('GPL3')
+depends=('plasma-framework' 'hicolor-icon-theme' 'knotifications')
+makedepends=('extra-cmake-modules')
+install=${pkgname}.install
+source=('https://github.com/anthon38/gmailfeed/archive/v1.1.tar.gz')
+md5sums=('dce518313585f1e1c4da2cbdf0f8c676')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ mkdir build
+ cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"/build
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/kdeplasma-applets-gmailfeed.install b/kdeplasma-applets-gmailfeed.install
new file mode 100644
index 000000000000..4f1d6880a66a
--- /dev/null
+++ b/kdeplasma-applets-gmailfeed.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file