summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-07-14 15:20:37 +0200
committerTimothy Redaelli2015-07-14 15:20:37 +0200
commit33327e054fcda49514672b14655998496cb4f8c8 (patch)
tree20222b9f420b42d498e98cdfbc17fe5fa537ef1e
downloadaur-33327e054fcda49514672b14655998496cb4f8c8.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--gxmailnotify.install4
-rw-r--r--mail_checker.cpp.patch11
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a739fdcebc90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kdeplasma-applets-gx-mail-notify
+ pkgdesc = Plasmoid for checking unreaded e-mails.
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = http://www.kde-look.org/content/show.php?content=99617
+ install = gxmailnotify.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ depends = kdebase-workspace
+ conflicts = plasma-gx-mail-notify-plasmoid
+ replaces = plasma-gx-mail-notify-plasmoid
+ source = http://www.kde-look.org/CONTENT/content-files/99617-gx_mail_notify-0.4.4.tar.bz2
+ source = mail_checker.cpp.patch
+ md5sums = bc9bb6234f85abdfc630b94390c474bf
+ md5sums = afae43af219c3ddd6f3cf021cead6947
+
+pkgname = kdeplasma-applets-gx-mail-notify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..414e16737e5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: LinuxUser <archlinux-user@gmx.com>
+
+pkgname=kdeplasma-applets-gx-mail-notify
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="Plasmoid for checking unreaded e-mails."
+arch=('i686' 'x86_64')
+url="http://www.kde-look.org/content/show.php?content=99617"
+license=('GPL')
+conflicts=('plasma-gx-mail-notify-plasmoid')
+replaces=('plasma-gx-mail-notify-plasmoid')
+depends=('kdebase-workspace')
+makedepends=('cmake' 'automoc4')
+install=gxmailnotify.install
+source=("http://www.kde-look.org/CONTENT/content-files/99617-gx_mail_notify-$pkgver.tar.bz2" "mail_checker.cpp.patch")
+md5sums=('bc9bb6234f85abdfc630b94390c474bf'
+ 'afae43af219c3ddd6f3cf021cead6947')
+
+build() {
+ patch -p0 -d"$srcdir"/gx_mail_notify-$pkgver -i $srcdir/mail_checker.cpp.patch
+
+ mkdir -p "$srcdir"/build
+ cd "$srcdir"/build
+
+ cmake -DCMAKE_INSTALL_PREFIX="$(kde4-config --prefix)" -DCMAKE_BUILD_TYPE=Release ../gx_mail_notify-$pkgver
+ make
+}
+
+package() {
+ cd "$srcdir"/build
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/gxmailnotify.install b/gxmailnotify.install
new file mode 100644
index 000000000000..4d2532a6b70c
--- /dev/null
+++ b/gxmailnotify.install
@@ -0,0 +1,4 @@
+post_install()
+{
+ update-desktop-database -q
+}
diff --git a/mail_checker.cpp.patch b/mail_checker.cpp.patch
new file mode 100644
index 000000000000..45b503e960a5
--- /dev/null
+++ b/mail_checker.cpp.patch
@@ -0,0 +1,11 @@
+--- mail_checker.cpp.orig 2010-05-05 22:54:26.000000000 +0200
++++ mail_checker.cpp 2011-01-28 01:26:58.896666670 +0100
+@@ -19,7 +19,7 @@
+ #include <KDebug>
+
+ MailChecker::MailChecker(Account * account) : QObject(),
+- actual_action(CLOSE_CONNECTION), certificate_details_dialog(0), time_to_check(0), check_messages(-1), check_error(false)
++ actual_action(CLOSE_CONNECTION), certificate_details_dialog(0), time_to_check(0), check_messages(-1)
+ {
+ this->account = account;
+