summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiuseppe Calà2015-06-08 14:59:46 +0200
committerGiuseppe Calà2015-06-08 14:59:46 +0200
commit5d91dcd6e13f2f467d58771e81ef3f5eca955d92 (patch)
tree21bfa687deb8fc58d15ae6ec5ea64430b40c9769
downloadaur-5d91dcd6e13f2f467d58771e81ef3f5eca955d92.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f07fc54c35e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kdeplasma-applets-steamcompanion
+ pkgdesc = A plasmoid to track Steam's specials and deals.
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://kde-apps.org/content/show.php/Steam+Companion?content=141713
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automoc4
+ makedepends = cmake
+ depends = kdebase-workspace
+ provides = steamcompanion
+ replaces = steamcompanion
+ source = http://opendesktop.org/CONTENT/content-files/141713-steamcompanion.tar.gz
+ md5sums = 8356e0a5f9fbe4a7bdf5e8340687b309
+
+pkgname = kdeplasma-applets-steamcompanion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..812864aca196
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Giuseppe Calà <jiveaxe@gmail.com>
+
+pkgname=kdeplasma-applets-steamcompanion
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="A plasmoid to track Steam's specials and deals."
+arch=('i686' 'x86_64')
+url=(http://kde-apps.org/content/show.php/Steam+Companion?content=141713)
+license=('GPL')
+depends=('kdebase-workspace')
+makedepends=('automoc4' 'cmake')
+source=('http://opendesktop.org/CONTENT/content-files/141713-steamcompanion.tar.gz')
+md5sums=('8356e0a5f9fbe4a7bdf5e8340687b309')
+replaces=('steamcompanion')
+provides=('steamcompanion')
+
+build() {
+ cd ${srcdir}/steamcompanion
+
+ mkdir build
+ cd build
+ cmake ../ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` || return 1
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/steamcompanion/build
+
+ make DESTDIR=$pkgdir install || return 1
+}