summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora2n2022-11-15 18:48:21 +0100
committerAlan A2N Bouteiller2023-11-08 15:22:16 +0100
commit33f7d177254b6730482c20064162d43ab5249692 (patch)
tree7f6a088f867dff23180214b6b769306c99a81be7
downloadaur-33f7d177254b6730482c20064162d43ab5249692.tar.gz
remove unecessary files and folders for the aur
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fad40bc243f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kdeplasma-arch-update-notifier-git
+ pkgdesc = KDE plasmoid that lets you know when arch updates are required. Takes all repo's into account (core, extra, aur, ...).
+ pkgver = 4.2.1
+ pkgrel = 1
+ url = https://github.com/bouteillerAlan/archupdate
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = konsole
+ depends = pacman-contrib
+ depends = yay
+ depends = kdialog
+ optdepends = paru: paru support
+ source = git+https://github.com/bouteillerAlan/archupdate.git#tag=ddaf9d2d3e0b75c4ba3c39d1060cbc30190990b7?signed
+ validpgpkeys = 6A2ECC8A396F8A943A109A1E0F11C2A6BF79111E
+ sha256sums = SKIP
+
+pkgname = kdeplasma-arch-update-notifier-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..123a15b12299
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zip
+*.tar.gz
+.kdev4/*
+archupdate.kdev4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75f87a96da7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bouteiller a2n Alan <a2n.dev@pm.me>
+
+# git rev-parse tagName
+_tag=ddaf9d2d3e0b75c4ba3c39d1060cbc30190990b7
+_plasmoidName="a2n.archupdate.plasmoid"
+_souceName="archupdate"
+
+pkgname="kdeplasma-arch-update-notifier-git"
+# pkgver is updated automatically by the pkgver step
+pkgver=4.2.1
+pkgrel=1
+pkgdesc="KDE plasmoid that lets you know when arch updates are required. Takes all repo's into account (core, extra, aur, ...)."
+arch=("any")
+url="https://github.com/bouteillerAlan/archupdate"
+license=("GPL3")
+source=("git+${url}.git#tag=${_tag}?signed")
+depends=("konsole" "pacman-contrib" "yay" "kdialog")
+makedepends=("git")
+optdepends=("paru: paru support")
+sha256sums=("SKIP")
+validpgpkeys=(
+ 6A2ECC8A396F8A943A109A1E0F11C2A6BF79111E # Bouteiller a2n Alan <a2n.dev@pm.me>, retrieved from https://github.com/bouteillerAlan.gpg
+)
+
+pkgver() {
+ cd "${_souceName}"
+ git describe --tags | sed 's/^v//'
+}
+
+package() {
+ cd "${_souceName}"
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"/
+ find "${_plasmoidName}" -type f -exec install -Dm 644 "{}" "${pkgdir}/usr/share/plasma/plasmoids/{}" \;
+}
+