summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2020-07-09 20:02:42 -0600
committergustawho2020-07-09 20:02:42 -0600
commit66dc338c27bb50c4343d4295f7c8f889d957c75d (patch)
tree216148a55a2d858b390f25456d7c67ca080b9646
parent1068c7b8b7adf9fa454d33e7e690e7d76c9ae009 (diff)
downloadaur-66dc338c27bb50c4343d4295f7c8f889d957c75d.tar.gz
Fixed URL
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b83657ec4747..867486299f5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = kdevelop-valgrind-git
- pkgdesc = A plugin offering a full integration of the valgrind suite to KDevelop. (GIT version)
- pkgver = r1116.2e096e1
- pkgrel = 1
+ pkgdesc = A plugin offering a full integration of the valgrind suite to KDevelop (latest development version)
+ pkgver = r1140.cc8fa04
+ pkgrel = 2
url = http://www.kdevelop.org
- arch = i686
arch = x86_64
license = GPL
- makedepends = cmake
makedepends = git
makedepends = extra-cmake-modules
depends = qt5-base
@@ -14,7 +12,7 @@ pkgbase = kdevelop-valgrind-git
provides = kdevelop-valgrind
conflicts = kdevelop-valgrind
conflicts = kdev-valgrind
- source = git://anongit.kde.org/kdev-valgrind.git
+ source = git+https://invent.kde.org/kdevelop/kdev-valgrind.git
sha1sums = SKIP
pkgname = kdevelop-valgrind-git
diff --git a/PKGBUILD b/PKGBUILD
index dfa01cad2ba5..8745c93820af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+_gitname=kdev-valgrind
pkgname=kdevelop-valgrind-git
-pkgver=r1116.2e096e1
-pkgrel=1
-pkgdesc="A plugin offering a full integration of the valgrind suite to KDevelop. (GIT version)"
-arch=('i686' 'x86_64')
+pkgver=r1140.cc8fa04
+pkgrel=2
+pkgdesc="A plugin offering a full integration of the valgrind suite to KDevelop (latest development version)"
+arch=('x86_64')
url='http://www.kdevelop.org'
license=('GPL')
depends=('qt5-base' 'valgrind')
conflicts=('kdevelop-valgrind' 'kdev-valgrind')
provides=('kdevelop-valgrind')
-makedepends=('cmake' 'git' 'extra-cmake-modules')
-source=("git://anongit.kde.org/kdev-valgrind.git")
+makedepends=('git' 'extra-cmake-modules')
+source=("git+https://invent.kde.org/kdevelop/kdev-valgrind.git")
sha1sums=('SKIP')
pkgver() {
- cd kdev-valgrind
+ cd "${srcdir}/${_gitname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- mkdir build
+ cd "${srcdir}/${_gitname}"
+ mkdir -p build
}
build() {
- cd build
- cmake ../kdev-valgrind \
+ cd "${srcdir}/${_gitname}/build"
+ cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
@@ -35,5 +37,6 @@ build() {
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${_gitname}/build"
+ make DESTDIR="${pkgdir}" install
}