summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-03 06:55:34 +1300
committercaltlgin2020-10-03 06:55:34 +1300
commita2371bf0c7fcfdc369451f9a4fc52dd0a3f25cfd (patch)
treee42805ed31964d21f2e6a9dd3bc48a3f015b86cb
downloadaur-a2371bf0c7fcfdc369451f9a4fc52dd0a3f25cfd.tar.gz
Add to AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f59e778638d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kdiskmark-git
+ pkgdesc = Simple disk benchmark tool
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/JonMagon/KDiskMark
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = qt5-tools
+ depends = fio
+ depends = hicolor-icon-theme
+ depends = qt5-base
+ provides = kdiskmark
+ source = KDiskMark::git+https://github.com/JonMagon/KDiskMark.git
+ sha256sums = SKIP
+
+pkgname = kdiskmark-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3532af4e55ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='KDiskMark'
+pkgname="${_pkgname,,}-git"
+pkgver=0.2.5
+pkgrel=1
+pkgdesc='Simple disk benchmark tool'
+arch=('x86_64')
+url='https://github.com/JonMagon/KDiskMark'
+license=('GPL3')
+depends=('fio' 'hicolor-icon-theme' 'qt5-base')
+makedepends=('extra-cmake-modules' 'git' 'qt5-tools')
+provides=("${_pkgname,,}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname,,}" "${_pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: