summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Hasting2020-01-22 11:08:21 -0500
committerDan Hasting2020-01-22 11:08:21 -0500
commit1c72c4b479dffb1481671c3bc26dadbc44d2c31f (patch)
tree360a8c7a118d8b155223e64a108d1e072c60c387
parent637bd02bbea62a296c78da47b1095d8b04e14f7a (diff)
downloadaur-1c72c4b479dffb1481671c3bc26dadbc44d2c31f.tar.gz
Patch for Qt 5.14
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--qt_514_build_fix.patch23
3 files changed, 27 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49b53c197169..08e344919d4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kdocker
pkgdesc = An application to help you dock any application into the system tray
pkgver = 5.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/user-none/KDocker
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index be03d88b3e6c..9971a7d3b09f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=kdocker
pkgver=5.2
-pkgrel=1
+pkgrel=2
pkgdesc="An application to help you dock any application into the system tray"
arch=('i686' 'x86_64')
url="https://github.com/user-none/KDocker"
@@ -12,6 +12,8 @@ sha256sums=('ffcb11ac0cf50ae80a35e000b7a7470259e624511d1281579386a9cb68935cba')
build() {
cd "$srcdir/KDocker-$pkgver"
+ patch --forward --strip=1 --input="../../qt_514_build_fix.patch" src/trayitem.h
+
qmake-qt5
make
}
diff --git a/qt_514_build_fix.patch b/qt_514_build_fix.patch
new file mode 100644
index 000000000000..7a73aa4dcdeb
--- /dev/null
+++ b/qt_514_build_fix.patch
@@ -0,0 +1,23 @@
+--- trayitem.h.old 2018-07-25 16:26:43.000000000 -0400
++++ trayitem.h 2020-01-22 11:02:25.406496065 -0500
+@@ -21,6 +21,9 @@
+ #ifndef _TRAYITEM_H
+ #define _TRAYITEM_H
+
++#pragma push_macro("None")
++#undef None
++
+ #include <QAction>
+ #include <QEvent>
+ #include <QIcon>
+@@ -32,6 +35,10 @@
+
+ #include "xlibutil.h"
+
++#ifndef None
++#pragma pop_macro("None")
++#endif
++
+ #define DEFAULT_CustomIcon QString()
+ #define DEFAULT_BalloonTimeout 4000 // 4 seconds
+ #define DEFAULT_SkipTaskbar false