summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Hasting2015-10-05 18:22:17 -0400
committerDan Hasting2015-10-05 18:22:17 -0400
commit9df049cad270dce5fbbef6c665ee0568717a7bde (patch)
tree4329b2058b02c2f97496e45b47454fb5c80d0eb1
parenta32c5642f951b179b96021bdd61a8e1b12783d7a (diff)
downloadaur-9df049cad270dce5fbbef6c665ee0568717a7bde.tar.gz
Patch for commit 9c62238
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c26b8a1774b..52b1179d2a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kdocker
pkgdesc = An application to help you dock any application into the system tray
pkgver = 5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/user-none/KDocker
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ea507aeb67f5..b724e4dd8417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=kdocker
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="An application to help you dock any application into the system tray"
arch=('i686' 'x86_64')
url="https://github.com/user-none/KDocker"
@@ -12,8 +12,12 @@ sha256sums=('711c3a07d36d278eca47fa56db34fcb0f20f30210d9a1e86a9d0243b834e357a')
build() {
cd "$srcdir/KDocker-$pkgver"
+ # Fix building with Qt 5.5
sed -i '/<QCoreApplication>/ a\#include <QDataStream>' 3rdparty/qtsingleapplication/src/qtlocalpeer.cpp
+ # Make sure to restore docked applications on exit
+ sed -i '/delete m_trayItemManager;/ i\m_trayItemManager->undockAll();' src/kdocker.cpp
+
qmake-qt5
make
}