summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-07-13 16:12:47 -0300
committerDanilo J. S. Bellini2018-07-13 16:12:47 -0300
commit866e43051d8e737c114be8599d55d11613c423fd (patch)
tree1500475ef758b7e512c230ccf97e9d6ab1d6ab59
parent774567e375d3b9b5263f902e40e4c176250aa63d (diff)
downloadaur-866e43051d8e737c114be8599d55d11613c423fd.tar.gz
v1.4.9-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f49cadd75b67..056d98201302 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kealib
pkgdesc = An HDF5 Based Raster File Format and its GDAL plugin
- pkgver = 1.4.7
+ pkgver = 1.4.9
pkgrel = 1
url = http://kealib.org
arch = i686
@@ -12,8 +12,8 @@ pkgbase = kealib
depends = hdf5-cpp-fortran
depends = gdal
options = !emptydirs
- source = https://bitbucket.org/chchrsc/kealib/downloads/kealib-1.4.7.tar.gz
- sha256sums = ec38751b3b555d3a26f0c7445f2d2cd9d7c3a3502237519a206a50cb58df56ec
+ source = https://bitbucket.org/chchrsc/kealib/downloads/kealib-1.4.9.tar.gz
+ sha256sums = 1c80489f17114a229097c2e8c61d5e4c82ea63ae631c81a817fef95cfd527174
pkgname = kealib
diff --git a/PKGBUILD b/PKGBUILD
index 6e6ce8cd3a61..3ac90918cec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('kealib')
-pkgver=1.4.7
+pkgver=1.4.9
pkgrel=1
pkgdesc="An HDF5 Based Raster File Format and its GDAL plugin"
arch=('i686' 'x86_64')
@@ -10,15 +10,14 @@ makedepends=('hdf5-cpp-fortran' 'gdal' 'cmake')
depends=('hdf5-cpp-fortran' 'gdal')
options=(!emptydirs)
source=("https://bitbucket.org/chchrsc/kealib/downloads/kealib-$pkgver.tar.gz")
-sha256sums=('ec38751b3b555d3a26f0c7445f2d2cd9d7c3a3502237519a206a50cb58df56ec')
-_srcpath=$pkgname-$pkgver/trunk
+sha256sums=('1c80489f17114a229097c2e8c61d5e4c82ea63ae631c81a817fef95cfd527174')
+_srcpath=$pkgname-$pkgver
prepare() {
- cd "$srcdir/$_srcpath"
-
- # Creates a standalone license file joining the copyright message
- # from everywhere in the code
- grep -rh -B1 -A22 'Copyright ' | sed 's/^[ *#]*//g;s/\r//g' > LICENSE
+ # The C++ standard required for compilation should be 11
+ # since the code uses stuff like static_assert and nullptr,
+ # but CMakeLists.txt hardcoded the 98 standard
+ sed -i /CMAKE_CXX_STANDARD.98/d "$srcdir/$_srcpath/CMakeLists.txt"
}
build() {
@@ -27,9 +26,7 @@ build() {
-D CMAKE_SKIP_RPATH=ON \
-D CMAKE_CXX_STANDARD=11 \
-D HDF5_INCLUDE_DIR=/usr/include \
- -D HDF5_LIB_PATH=/usr/lib \
-D GDAL_INCLUDE_DIR=/usr/include \
- -D GDAL_LIB_PATH=/usr/lib \
-D LIBKEA_WITH_GDAL=TRUE \
.
make
@@ -38,5 +35,5 @@ build() {
package() {
cd "$srcdir/$_srcpath"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}