summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc DELAGE2017-01-12 15:08:01 +0100
committerMarc DELAGE2017-01-12 15:36:12 +0100
commit052ce713a74bc3b1d0fdaae1a2e9d43a908cf381 (patch)
tree4e8f33dae60bdc3dc5c91204d862d7ed04456831
parent8d6d975ef49c07bc2d005f517db3da35faff2d7f (diff)
downloadaur-052ce713a74bc3b1d0fdaae1a2e9d43a908cf381.tar.gz
version 3.2-3
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD21
-rw-r--r--keeex.desktop17
4 files changed, 28 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d589bea989a6..fc6279a165c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,13 @@ pkgbase = keeex
depends = gconf
depends = libnotify
source = https://downloads.keeex.io/latest/keeex.linux64.zip
+ source = https://keeex.me/pkgfiles/icon.png
source = keeex.desktop
- source = LICENSE
+ source = https://keeex.me/pkgfiles/LICENSE
sha512sums = 4a168d2e36aea11cebcae6cffe4df16df0b4af9d2b1bae4b1c2d438353bcb48def57efcac52cbd98198feddbe5547b657aea157038bc3b90f51228c855dcd596
- sha512sums = f2f94f81d3616cbbcebfb1355b84c72c6f131f406e2a074119d5eaa2cbc6740f9a251f464d45568698b1d8420751bd2c75b8c64da5fc4d4305849d901a0c5ac7
- sha512sums = 4c020bd39625488476f7dabaef9a289eff51af00c1b1d6e72c00bc306aadf7109aac4a785e1d56c3b7d2160b2e046e7a7d90e36835f8d12c4baefe0b128021bb
+ sha512sums = a0dd5edb226531602db1e5796327f0674fcc944ab4868e1b96d9028f6c6756b08cb71654cac6249f87700427a4c9057c1f36389b53055ca3714628a2930f6da7
+ sha512sums = c33b17e4ea2952d0bdf5f09fb8d97674de2d38401813a404a49a69b9800045eeb0cf8afc6c06ea59f5eb9696fc341d98dae94b4263aa4a836c8fb2e5426402ad
+ sha512sums = ed5e531303fefc75b839a5778fd4e83166d0263bc1aa68672919dee013eda391b61b34600c580ed7ab5f94e70523ce64e0679bac18dc25a25230c032b00d5b56
pkgname = keeex
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 23066ea4cd5f..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,9 +0,0 @@
-KeeeX belongs to KeeeX SAS, all rights reserved.
-
-The software is delivered "as is" and we take no responsibility for
-any problems that arise from usage.
-
-KeeeX may be redistributed by third parties only when free of
-charge or advertisements and without modifications to the
-included source code or resource files.
-
diff --git a/PKGBUILD b/PKGBUILD
index 6970e4ad856e..9b6a73110b36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Alexandre Pujol <alexandre@pujol.io>
+# Contributor: Maxence Mohr <maxence@keeex.net>
pkgname='keeex'
pkgver=3.2
-pkgrel=1
+pkgrel=3
pkgdesc='Fully operational blockchain solutions for securing, chaining, sharing, signing and timestamping any kind of document, data or process with no alteration.'
arch=('x86_64')
url='https://keeex.me/'
@@ -15,24 +16,28 @@ depends=('hidapi'
'gconf'
'libnotify')
source=("https://downloads.keeex.io/latest/keeex.linux64.zip"
+ "https://keeex.me/pkgfiles/icon.png"
"keeex.desktop"
- "LICENSE")
+ "https://keeex.me/pkgfiles/LICENSE")
sha512sums=('4a168d2e36aea11cebcae6cffe4df16df0b4af9d2b1bae4b1c2d438353bcb48def57efcac52cbd98198feddbe5547b657aea157038bc3b90f51228c855dcd596'
- 'f2f94f81d3616cbbcebfb1355b84c72c6f131f406e2a074119d5eaa2cbc6740f9a251f464d45568698b1d8420751bd2c75b8c64da5fc4d4305849d901a0c5ac7'
- '4c020bd39625488476f7dabaef9a289eff51af00c1b1d6e72c00bc306aadf7109aac4a785e1d56c3b7d2160b2e046e7a7d90e36835f8d12c4baefe0b128021bb')
+ 'a0dd5edb226531602db1e5796327f0674fcc944ab4868e1b96d9028f6c6756b08cb71654cac6249f87700427a4c9057c1f36389b53055ca3714628a2930f6da7'
+ 'c33b17e4ea2952d0bdf5f09fb8d97674de2d38401813a404a49a69b9800045eeb0cf8afc6c06ea59f5eb9696fc341d98dae94b4263aa4a836c8fb2e5426402ad'
+ 'ed5e531303fefc75b839a5778fd4e83166d0263bc1aa68672919dee013eda391b61b34600c580ed7ab5f94e70523ce64e0679bac18dc25a25230c032b00d5b56')
_execname="KeeeX"
+_target_dir="/opt"
+options=("!strip")
package() {
cd "${srcdir}/"
- install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ install -dm755 "${pkgdir}${_target_dir}/${pkgname}"
install -dm755 "${pkgdir}/usr/bin"
# Program
- install -Dm755 "${_execname}" "${pkgdir}/usr/lib/${pkgname}/"
- install -Dm644 "nw.pak" "libffmpegsumo.so" "icudtl.dat" "${pkgdir}/usr/lib/${pkgname}/"
+ install -Dm755 "${_execname}" "${pkgdir}${_target_dir}/${pkgname}/"
+ install -Dm644 "icon.png" "nw.pak" "libffmpegsumo.so" "icudtl.dat" "${pkgdir}${_target_dir}/${pkgname}/"
# Link to program
- ln -s "/usr/lib/${pkgname}/${_execname}" "${pkgdir}/usr/bin/${_execname}"
+ ln -s "${_target_dir}/${pkgname}/${_execname}" "${pkgdir}/usr/bin/${_execname,,}"
# Desktop file
install -Dm644 "keeex.desktop" "${pkgdir}/usr/share/applications/keeex.desktop"
diff --git a/keeex.desktop b/keeex.desktop
index b62e0440699b..290b2d52c813 100644
--- a/keeex.desktop
+++ b/keeex.desktop
@@ -1,9 +1,12 @@
[Desktop Entry]
-Name=KeeeX
-Comment=Fully operational blockchain solutions for securing, chaining, sharing, signing and timestamping any kind of document, data or process with no alteration.
-Exec=KeeeX %U
-Icon=KeeeX
-MimeType=application/x-bittorrent;x-scheme-handler/magnet;
-StartupNotify=false
-Categories=Internet;
+Encoding=UTF-8
+Version=3.2.0
+Name=KeeeX ChatOps
+GenericName=KeeeX
+Exec=/opt/keeex/KeeeX
+Terminal=false
+Icon=/opt/keeex/icon.png
Type=Application
+Categories=Application;Network;Security;
+Comment[en]=Secure file collaboration
+Comment[fr]=Collaboration sécurisée de fichiers