summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Pujol2017-01-10 18:58:07 +0000
committerAlexandre Pujol2017-01-10 18:58:07 +0000
commit8d6d975ef49c07bc2d005f517db3da35faff2d7f (patch)
treeb6bee3a8c78b66f2b6769ffd9c411939bb1a5de5
downloadaur-8d6d975ef49c07bc2d005f517db3da35faff2d7f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD42
-rw-r--r--keeex.desktop9
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d589bea989a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = keeex
+ pkgdesc = Fully operational blockchain solutions for securing, chaining, sharing, signing and timestamping any kind of document, data or process with no alteration.
+ pkgver = 3.2
+ pkgrel = 1
+ url = https://keeex.me/
+ arch = x86_64
+ license = custom
+ depends = hidapi
+ depends = libxtst
+ depends = gtk2
+ depends = nss
+ depends = alsa-lib
+ depends = gconf
+ depends = libnotify
+ source = https://downloads.keeex.io/latest/keeex.linux64.zip
+ source = keeex.desktop
+ source = LICENSE
+ sha512sums = 4a168d2e36aea11cebcae6cffe4df16df0b4af9d2b1bae4b1c2d438353bcb48def57efcac52cbd98198feddbe5547b657aea157038bc3b90f51228c855dcd596
+ sha512sums = f2f94f81d3616cbbcebfb1355b84c72c6f131f406e2a074119d5eaa2cbc6740f9a251f464d45568698b1d8420751bd2c75b8c64da5fc4d4305849d901a0c5ac7
+ sha512sums = 4c020bd39625488476f7dabaef9a289eff51af00c1b1d6e72c00bc306aadf7109aac4a785e1d56c3b7d2160b2e046e7a7d90e36835f8d12c4baefe0b128021bb
+
+pkgname = keeex
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..23066ea4cd5f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+KeeeX belongs to KeeeX SAS, all rights reserved.
+
+The software is delivered "as is" and we take no responsibility for
+any problems that arise from usage.
+
+KeeeX may be redistributed by third parties only when free of
+charge or advertisements and without modifications to the
+included source code or resource files.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6970e4ad856e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alexandre Pujol <alexandre@pujol.io>
+
+pkgname='keeex'
+pkgver=3.2
+pkgrel=1
+pkgdesc='Fully operational blockchain solutions for securing, chaining, sharing, signing and timestamping any kind of document, data or process with no alteration.'
+arch=('x86_64')
+url='https://keeex.me/'
+license=('custom')
+depends=('hidapi'
+ 'libxtst'
+ 'gtk2'
+ 'nss'
+ 'alsa-lib'
+ 'gconf'
+ 'libnotify')
+source=("https://downloads.keeex.io/latest/keeex.linux64.zip"
+ "keeex.desktop"
+ "LICENSE")
+sha512sums=('4a168d2e36aea11cebcae6cffe4df16df0b4af9d2b1bae4b1c2d438353bcb48def57efcac52cbd98198feddbe5547b657aea157038bc3b90f51228c855dcd596'
+ 'f2f94f81d3616cbbcebfb1355b84c72c6f131f406e2a074119d5eaa2cbc6740f9a251f464d45568698b1d8420751bd2c75b8c64da5fc4d4305849d901a0c5ac7'
+ '4c020bd39625488476f7dabaef9a289eff51af00c1b1d6e72c00bc306aadf7109aac4a785e1d56c3b7d2160b2e046e7a7d90e36835f8d12c4baefe0b128021bb')
+_execname="KeeeX"
+
+package() {
+ cd "${srcdir}/"
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+
+ # Program
+ install -Dm755 "${_execname}" "${pkgdir}/usr/lib/${pkgname}/"
+ install -Dm644 "nw.pak" "libffmpegsumo.so" "icudtl.dat" "${pkgdir}/usr/lib/${pkgname}/"
+
+ # Link to program
+ ln -s "/usr/lib/${pkgname}/${_execname}" "${pkgdir}/usr/bin/${_execname}"
+
+ # Desktop file
+ install -Dm644 "keeex.desktop" "${pkgdir}/usr/share/applications/keeex.desktop"
+
+ # Copy license
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/keeex.desktop b/keeex.desktop
new file mode 100644
index 000000000000..b62e0440699b
--- /dev/null
+++ b/keeex.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=KeeeX
+Comment=Fully operational blockchain solutions for securing, chaining, sharing, signing and timestamping any kind of document, data or process with no alteration.
+Exec=KeeeX %U
+Icon=KeeeX
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;
+StartupNotify=false
+Categories=Internet;
+Type=Application