summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGenerator2017-10-21 19:14:28 +0100
committerGenerator2017-10-21 19:14:28 +0100
commit4157e8e76a22048943e885b53e8f1d259a31fcf4 (patch)
tree90a6e518fef715073290527ffd9061b8e51c72d0
parentc32164d842ea7a6fdc8e37cb29b0118747174ae4 (diff)
downloadaur-4157e8e76a22048943e885b53e8f1d259a31fcf4.tar.gz
Bump version 1.2.1
Use DLLs till #9 is fixed
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 119ba10a4967..8dfaa6b3cfc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
# Generated by mksrcinfo v8
-# Fri May 26 12:39:18 UTC 2017
+# Sat Oct 21 18:13:28 UTC 2017
pkgbase = keepass-plugin-haveibeenpwned
pkgdesc = KeePass plugin to check all entries with URLs against the "Have I Been Pwned?" and Cloudbleed breach list
- pkgver = 0.3.1
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/andrew-schofield/keepass2-haveibeenpwned
arch = any
license = MIT
depends = keepass
- source = https://github.com/andrew-schofield/keepass2-haveibeenpwned/releases/download/v0.3.1/HaveIBeenPwned.plgx
- sha512sums = a59a0efab76cdcca549c264320fd15847cc4cd379bc8223427009aaacb14aa50cd502940574055290be644a122346af5be1da0786073c23faa2409bf0018f472
+ source = https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/mono/HaveIBeenPwned.dll
+ source = https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/mono/Newtonsoft.Json.dll
+ source = https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/mono/keepass2-developerextensions.dll
+ sha512sums = c9b020cbd14e0a1e09dda2e46167865eaee264dd95b323c0c2321a63d128e19a58e15eab0bec86b96d38f096b6579a89d0006622f39998824537fbfa343f0dae
+ sha512sums = 96754c8a846311ca59f8ec38185c2a204017bc8bc73bae1fdee63b66f3cc459017ed34ca164b53d625abfae683683b278e1aaa66346023018411ae70fe9e8059
+ sha512sums = 02563d4d42b4c967815156ac66cce4c03100fc9413a58f4cd585953d8189fab263c34e50548ccde9beb4fb533fc6014936d3675a8118653a9074f44013077fe0
pkgname = keepass-plugin-haveibeenpwned
diff --git a/PKGBUILD b/PKGBUILD
index a1c299a0603e..60ea963081d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,22 @@
_pkgname=HaveIBeenPwned
pkgname=keepass-plugin-haveibeenpwned
-pkgver=0.3.1
+pkgver=1.2.1
pkgrel=1
pkgdesc='KeePass plugin to check all entries with URLs against the "Have I Been Pwned?" and Cloudbleed breach list'
license=('MIT')
depends=('keepass')
arch=('any')
url="https://github.com/andrew-schofield/keepass2-haveibeenpwned"
-source=("https://github.com/andrew-schofield/keepass2-haveibeenpwned/releases/download/v${pkgver}/${_pkgname}.plgx")
-sha512sums=('a59a0efab76cdcca549c264320fd15847cc4cd379bc8223427009aaacb14aa50cd502940574055290be644a122346af5be1da0786073c23faa2409bf0018f472')
+source=("https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/mono/HaveIBeenPwned.dll"
+ "https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/mono/Newtonsoft.Json.dll"
+ "https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/mono/keepass2-developerextensions.dll")
+sha512sums=('c9b020cbd14e0a1e09dda2e46167865eaee264dd95b323c0c2321a63d128e19a58e15eab0bec86b96d38f096b6579a89d0006622f39998824537fbfa343f0dae'
+ '96754c8a846311ca59f8ec38185c2a204017bc8bc73bae1fdee63b66f3cc459017ed34ca164b53d625abfae683683b278e1aaa66346023018411ae70fe9e8059'
+ '02563d4d42b4c967815156ac66cce4c03100fc9413a58f4cd585953d8189fab263c34e50548ccde9beb4fb533fc6014936d3675a8118653a9074f44013077fe0')
package() {
- install -Dm644 "${srcdir}"/${_pkgname}.plgx "${pkgdir}"/usr/share/keepass/plugins/${_pkgname}.plgx
+ install -Dm644 "${srcdir}"/HaveIBeenPwned.dll "${pkgdir}"/usr/share/keepass/plugins/HaveIBeenPwned.dll
+ install -Dm644 "${srcdir}"/Newtonsoft.Json.dll "${pkgdir}"/usr/share/keepass/plugins/Newtonsoft.Json.dll
+ install -Dm644 "${srcdir}"/keepass2-developerextensions.dll "${pkgdir}"/usr/share/keepass/plugins/keepass2-developerextensions.dll
}