summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGenerator2017-03-15 17:18:52 +0000
committerGenerator2017-03-15 17:18:52 +0000
commitcd8890d5ac88d8ac8304d2b77a6cba873278787e (patch)
tree19dcca464e56b765f940e43abc3452894b12afc2
downloadaur-cd8890d5ac88d8ac8304d2b77a6cba873278787e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52fa08552dbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Mar 15 17:17:52 UTC 2017
+pkgbase = keepass-plugin-haveibeenpwned
+ pkgdesc = KeePass plugin to check all entries with URLs against the "Have I Been Pwned?" and Cloudbleed breach list
+ pkgver = 0.2.4.1
+ pkgrel = 1
+ url = https://github.com/andrew-schofield/keepass2-haveibeenpwned
+ arch = any
+ license = MIT
+ depends = keepass
+ source = https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/HaveIBeenPwned.plgx
+ sha512sums = 72f6be3afddac9280cdce21f23e24852aebdf0f0ddae2ae2be79f8f13bf9a9ac02f9a1e31c2aa297982ad90d3c911bc38eb31b251fe51f626c728b1f56e4db7c
+
+pkgname = keepass-plugin-haveibeenpwned
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bf382c2ab99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: American_Jesus <american.jesus.pt AT gmail DOT com>
+
+_pkgname=HaveIBeenPwned
+pkgname=keepass-plugin-haveibeenpwned
+pkgver=0.2.4.1
+pkgrel=1
+pkgdesc='KeePass plugin to check all entries with URLs against the "Have I Been Pwned?" and Cloudbleed breach list'
+license=('MIT')
+depends=('keepass')
+arch=('any')
+url="https://github.com/andrew-schofield/keepass2-haveibeenpwned"
+source=("https://github.com/andrew-schofield/keepass2-haveibeenpwned/raw/master/${_pkgname}.plgx")
+sha512sums=('72f6be3afddac9280cdce21f23e24852aebdf0f0ddae2ae2be79f8f13bf9a9ac02f9a1e31c2aa297982ad90d3c911bc38eb31b251fe51f626c728b1f56e4db7c')
+
+package() {
+ install -Dm644 "${srcdir}"/${_pkgname}.plgx "${pkgdir}"/usr/share/keepass/plugins/${_pkgname}.plgx
+}