summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Manouchehri2015-10-05 23:15:47 -0400
committerDavid Manouchehri2015-10-05 23:15:47 -0400
commit85b98ec2ab67f2a20f20df74d607d088e1d3adb2 (patch)
treeec13a83722ad1cfbc2ef30df3481e17e79db4db2
parent121b1c655a965f91cf551b09cf51cbc84a1fe007 (diff)
downloadaur-85b98ec2ab67f2a20f20df74d607d088e1d3adb2.tar.gz
Initial creation of the OtpKeyProv package.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e264e2159dc..459f4fbb2497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
-pkgbase = keepass-plugin-keechallenge
- pkgdesc = A plugin that allows to use the yubikey HMAC-SHA1 challenge-response functionality in Keepass.
- pkgver = 1.4.0
- pkgrel = 2
- url = http://sourceforge.net/projects/keechallenge/
+pkgbase = keepass-plugin-otpkeyprov
+ pkgdesc = A plugin that allows to use the YubiKey OTP functionality in Keepass.
+ pkgver = 2.4
+ pkgrel = 1
+ url = http://keepass.info/plugins.html#otpkeyprov
arch = i686
arch = x86_64
license = GPL2
depends = keepass
optdepends = yubikey-personalization: For configuring a YubiKey
- source = http://sourceforge.net/projects/keechallenge/files/KeeChallenge/bin/KeeChallenge_1.4_win.zip
- md5sums = 7c2f5d8ccbe9549767ca15de0fbf7383
- sha512sums = a6d329b29e1bb71e6a4e73fa4f65476749bbd2b02ce9350f51f2b396ee76d231614a6149ce2705ca7bea8aa6ff7ca921b58d8995e258eb1eb5be9ae9a38ca285
+ source = http://keepass.info/extensions/v2/otpkeyprov/OtpKeyProv-2.4.zip
+ sha512sums = a63721e5d2ae81786d4e64d316799d066459a53e911fc71558f354aaa67d8199ef2cca1172bfdff86aedfab895ce872e0a06cef4eb2e34ecec69ebaf5639cf86
-pkgname = keepass-plugin-keechallenge
+pkgname = keepass-plugin-otpkeyprov
diff --git a/PKGBUILD b/PKGBUILD
index fcf986ea5335..12f2ad765b0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
-# Maintainer: Nils B. <aur@theinbox.de>
-# Contributor: David Manouchehri <manouchehri@riseup.net>
+# Maintainer: David Manouchehri <manouchehri@riseup.net>
+# Contributor: Nils B. <aur@theinbox.de>
-pkgname=keepass-plugin-keechallenge
-pkgver=1.4.0
-pkgrel=2
-pkgdesc="A plugin that allows to use the yubikey HMAC-SHA1 challenge-response functionality in Keepass."
+_pkggroup='keepass-plugin'
+_pkgname='otpkeyprov'
+pkgname="${_pkggroup}-${_pkgname}"
+pkgver='2.4'
+pkgrel=1
+pkgdesc="A plugin that allows to use the YubiKey OTP functionality in Keepass."
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/keechallenge/"
+url="http://keepass.info/plugins.html#${_pkgname}"
license=('GPL2')
depends=('keepass')
optdepends=('yubikey-personalization: For configuring a YubiKey')
-_zipname="KeeChallenge_1.4_win"
-source=(http://sourceforge.net/projects/keechallenge/files/KeeChallenge/bin/${_zipname}.zip)
-
-build() {
- cd ${srcdir}
-
-}
+source=("http://keepass.info/extensions/v2/${_pkgname}/OtpKeyProv-${pkgver}.zip")
+sha512sums=('a63721e5d2ae81786d4e64d316799d066459a53e911fc71558f354aaa67d8199ef2cca1172bfdff86aedfab895ce872e0a06cef4eb2e34ecec69ebaf5639cf86')
package() {
- cd ${srcdir}
- install -D -m 644 KeeChallenge.dll.config ${pkgdir}/usr/share/keepass/plugins/KeeChallenge.dll.config
- install -D -m 644 KeeChallenge.dll ${pkgdir}/usr/share/keepass/plugins/KeeChallenge.dll
+ cd "${srcdir}"
+ install -Dm 644 'OtpKeyProv.plgx' "${pkgdir}/usr/share/keepass/plugins/OtpKeyProv.plgx"
}
-md5sums=('7c2f5d8ccbe9549767ca15de0fbf7383')
-sha512sums=('a6d329b29e1bb71e6a4e73fa4f65476749bbd2b02ce9350f51f2b396ee76d231614a6149ce2705ca7bea8aa6ff7ca921b58d8995e258eb1eb5be9ae9a38ca285')
+# vim:set et sw=2 sts=2 tw=80: \ No newline at end of file