summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-08-16 02:09:34 +0200
committerTimothy Redaelli2015-08-16 02:09:34 +0200
commitc03a7d5a1ddf115842595194cf6d7bfbe5437357 (patch)
tree909fe5b9141907c7a04b17fc18aff1e520d595d7
downloadaur-c03a7d5a1ddf115842595194cf6d7bfbe5437357.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e16fdb1516f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = keepass-serpentcipher
+ pkgdesc = Enables KeePass to encrypt databases using the serpent algorithm.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/drizzt/KeePass-SerpentCipher/
+ arch = any
+ license = GPL3
+ depends = keepass
+ source = https://github.com/drizzt/KeePass-SerpentCipher/releases/download/v1.0/SerpentCipher-1.0.zip
+ sha256sums = 5e52d648845bc955ad18609313e8ce415a7d5cb5ddc342845656cc131518c8b3
+
+pkgname = keepass-serpentcipher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ffcdf12f55c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+pkgname=keepass-serpentcipher
+_pkgname=SerpentCipher
+pkgver=1.0
+pkgrel=1
+pkgdesc="Enables KeePass to encrypt databases using the serpent algorithm."
+license=('GPL3')
+depends=('keepass')
+arch=('any')
+url="https://github.com/drizzt/KeePass-SerpentCipher/"
+source=("https://github.com/drizzt/KeePass-SerpentCipher/releases/download/v$pkgver/$_pkgname-$pkgver.zip")
+sha256sums=('5e52d648845bc955ad18609313e8ce415a7d5cb5ddc342845656cc131518c8b3')
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/keepass
+ install -m644 "$_pkgname.plgx" "${pkgdir}"/usr/share/keepass
+}