summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2015-09-10 12:16:10 +0200
committerMichael Lass2015-09-10 12:16:10 +0200
commitadbf8c23c946979c8fb39a732e1ce617a3d9dc67 (patch)
tree576438b5dcf2085e714bc896f13a5fb08b48f096
parent007549efc06eabbda21bec6d4cd6fd1f345b95f7 (diff)
downloadaur-adbf8c23c946979c8fb39a732e1ce617a3d9dc67.tar.gz
Update to 2.0-beta2
Also change version string to include the 2.0 - otherwise there would be no version for the final release.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 916e1c509030..521ff641f946 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = keepassx2
pkgdesc = Crossplatform port of Windows' application ''KeePass Password Safe''
- pkgver = beta1
+ pkgver = 2.0beta2
pkgrel = 1
url = https://www.keepassx.org/dev/
install = keepassx2.install
@@ -16,8 +16,8 @@ pkgbase = keepassx2
conflicts = keepassx
conflicts = keepassx2-git
options = !emptydirs
- source = https://www.keepassx.org/dev/attachments/download/100/keepassx-2.0-beta1.tar.gz
- sha256sums = bce1933c48fd33ef8043dd526d769fd9c454d1b63464c82a35e1f7a8689acbf2
+ source = https://www.keepassx.org/dev/attachments/download/115/keepassx-2.0-beta2.tar.gz
+ sha256sums = 5828261226c441856bd12e2f4f73af1a5fc3b1981b2cff40fbc2403e344f4e52
pkgname = keepassx2
diff --git a/PKGBUILD b/PKGBUILD
index dacc9bc605a8..d8b872086843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,10 @@
# https://github.com/michaellass/AUR
pkgname=keepassx2
-pkgver=beta1
+pkgver=2.0beta2
pkgrel=1
+_dlver=2.0-beta2
+_dlno=115
pkgdesc="Crossplatform port of Windows' application ''KeePass Password Safe''"
arch=('i686' 'x86_64')
url="https://www.keepassx.org/dev/"
@@ -16,15 +18,15 @@ makedepends=('intltool' 'cmake')
conflicts=('keepassx' 'keepassx2-git')
options=(!emptydirs)
install=keepassx2.install
-source=("https://www.keepassx.org/dev/attachments/download/100/keepassx-2.0-${pkgver}.tar.gz")
-sha256sums=('bce1933c48fd33ef8043dd526d769fd9c454d1b63464c82a35e1f7a8689acbf2')
+source=("https://www.keepassx.org/dev/attachments/download/${_dlno}/keepassx-${_dlver}.tar.gz")
+sha256sums=('5828261226c441856bd12e2f4f73af1a5fc3b1981b2cff40fbc2403e344f4e52')
_cmake_keys="-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=/usr/lib
-DCMAKE_BUILD_TYPE=Release"
build() {
- cd "$srcdir/keepassx-2.0-$pkgver"
+ cd "${srcdir}/keepassx-${_dlver}"
if [[ -d build ]]; then
rm -rf build
@@ -36,6 +38,6 @@ build() {
}
package() {
- cd "$srcdir/keepassx-2.0-$pkgver/build"
+ cd "${srcdir}/keepassx-${_dlver}/build"
make DESTDIR="${pkgdir}" install
}