summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2024-02-23 12:02:36 +0100
committerNoah Vogt2024-02-23 12:02:36 +0100
commit3d402188d1ae51940ba70509454fedec782e9b5b (patch)
tree76ba15ffa53d98614e1dd847d1fb3e388caa94bf
parent9d22c4c71c6190b6d6f473594d22da29eb564f5a (diff)
downloadaur-3d402188d1ae51940ba70509454fedec782e9b5b.tar.gz
uppkg -> 2.7.6-3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--cc0530ba.patch31
3 files changed, 41 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f09f34213702..f14f7b5c6c13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keepassxc-allow-aur-extension-origin
pkgdesc = Cross-platform community-driven port of Keepass password manager
pkgver = 2.7.6
- pkgrel = 2
+ pkgrel = 3
url = https://keepassxc.org/
arch = x86_64
license = GPL
@@ -27,8 +27,10 @@ pkgbase = keepassxc-allow-aur-extension-origin
provides = keepassxc
conflicts = keepassxc
source = https://github.com/keepassxreboot/keepassxc/releases/download/2.7.6/keepassxc-2.7.6-src.tar.xz
+ source = https://github.com/keepassxreboot/keepassxc/commit/cc0530ba.patch
source = add-aur-extension-build-to-allowed-origins.patch
sha256sums = a58074509fa8e90f152c6247f73e75e126303081f55eedb4ea0cbb6fa980d670
+ sha256sums = 7884a0425a5bf7e67d389d6b2545b06ee28b6d77e9164df13a8e78b5719d11ce
sha256sums = a150f3ce0d9d8827b6c767aa673be4af298aafd6f46ddd10373e32b832dd2017
pkgname = keepassxc-allow-aur-extension-origin
diff --git a/PKGBUILD b/PKGBUILD
index 05f70cd32cd9..8e76d0dacc33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
+# Maintainer: Noah Vogt (noahvogt) <noah@noahvogt.com>
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
# Maintainer: Bruno Pagani <archange@archlinux.org>
pkgname=keepassxc-allow-aur-extension-origin
pkgver=2.7.6
-pkgrel=2
+pkgrel=3
pkgdesc="Cross-platform community-driven port of Keepass password manager"
arch=(x86_64)
url="https://keepassxc.org/"
@@ -17,8 +18,10 @@ checkdepends=(xclip xorg-server-xvfb)
provides=(org.freedesktop.secrets keepassxc)
conflicts=(keepassxc)
source=(https://github.com/keepassxreboot/keepassxc/releases/download/$pkgver/keepassxc-$pkgver-src.tar.xz
+ https://github.com/keepassxreboot/keepassxc/commit/cc0530ba.patch
add-aur-extension-build-to-allowed-origins.patch)
sha256sums=('a58074509fa8e90f152c6247f73e75e126303081f55eedb4ea0cbb6fa980d670'
+ '7884a0425a5bf7e67d389d6b2545b06ee28b6d77e9164df13a8e78b5719d11ce'
'a150f3ce0d9d8827b6c767aa673be4af298aafd6f46ddd10373e32b832dd2017')
# List of signing keys can be found at https://keepassxc.org/verifying-signatures/
# validpgpkeys=(BF5A669F2272CF4324C1FDA8CFB4C2166397D0D2
@@ -28,6 +31,9 @@ sha256sums=('a58074509fa8e90f152c6247f73e75e126303081f55eedb4ea0cbb6fa980d670'
prepare() {
cd keepassxc-"$pkgver"
+ # Fix build with botan 3.3
+ patch -p1 -i ../cc0530ba.patch
+
patch -p1 -i ../add-aur-extension-build-to-allowed-origins.patch
}
diff --git a/cc0530ba.patch b/cc0530ba.patch
new file mode 100644
index 000000000000..49506ebce50d
--- /dev/null
+++ b/cc0530ba.patch
@@ -0,0 +1,31 @@
+From cc0530ba4671a7e2b6ac4a6c00cd097f4114fd22 Mon Sep 17 00:00:00 2001
+From: Dan Church <amphetamachine@gmail.com>
+Date: Sun, 19 Nov 2023 11:05:21 -0600
+Subject: [PATCH] Fix Botan 2/3 include
+
+Botan::secure_scrub_memory -> defined in mem_ops.h
+Botan::secure_vector -> defined in secmem.h
+
+The reason only including secmem.h worked in previous (<3.0) versions of
+Botan was because secmem.h included mem_ops.h. This is no longer the
+case since commit
+randombit/botan@49dbbcb2bfda05ef9d3f09848c9ba22fcbcd5066 (2023-10-11;
+"Split out allocator helpers to allocator.h")
+
+Fixes #10038
+---
+ src/keys/FileKey.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/keys/FileKey.h b/src/keys/FileKey.h
+index 795f03bdbc..65cd955a7c 100644
+--- a/src/keys/FileKey.h
++++ b/src/keys/FileKey.h
+@@ -19,6 +19,7 @@
+ #ifndef KEEPASSX_FILEKEY_H
+ #define KEEPASSX_FILEKEY_H
+
++#include <botan/mem_ops.h>
+ #include <botan/secmem.h>
+
+ #include "keys/Key.h"