summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Van Petegem2017-09-06 11:11:03 +0200
committerEvert Van Petegem2017-09-06 11:11:03 +0200
commit744b45990818eb49e0c3d132ff5d6d9ce77c4112 (patch)
tree115e70d6d63aadbc369d1b65fce89528ef815e2b
downloadaur-744b45990818eb49e0c3d132ff5d6d9ce77c4112.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD61
-rw-r--r--keepassxc-browser.install19
4 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6767fe92fa12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = keepassxc-browser-git
+ pkgdesc = A reboot of an OpenSource password safe which helps you to manage your passwords in an easy and secure way with a modern browser extension
+ pkgver = 2.1.4.r579.g35ffd8f8
+ pkgrel = 1
+ url = https://github.com/varjolintu/keepassxc
+ install = keepassxc-browser.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = intltool
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = qt5-tools
+ makedepends = zlib
+ makedepends = libgcrypt
+ makedepends = boost
+ depends = libxtst
+ depends = shared-mime-info
+ depends = qt5-x11extras
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ depends = yubikey-personalization
+ depends = boost-libs
+ depends = libsodium
+ conflicts = keepassxc
+ conflicts = keepassxc-git
+ replaces = keepassx-http
+ replaces = keepassx-reboot-git
+ options = !emptydirs
+ source = git+https://github.com/varjolintu/keepassxc.git#branch=feature/chromeKeePassXC
+ md5sums = SKIP
+
+pkgname = keepassxc-browser-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..59f424aa104d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+keepassx-http-*.src.tar.gz
+keepassx-http-*.pkg.tar.xz
+keepassx/
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f8f455c0c79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Evert Van Petegem <evert [at] vanpetegem [dot] me>
+# Contributor: Daniel Landau <daniel@landau.fi>
+# Contributor: Maxqia <contrib@maxqia.com>
+
+# The following people have contributed to keepassx-git package
+# Contributor: Lev Lybin <aur@devtrue.net>
+# Contributor: Jamie Macdonald <jamie.alban@gmail.com>
+# Contributor: Alucryd <alucryd at gmail dot com>
+# Contributor: Paolo Stivanin <admin at polslinux dot it>
+
+pkgname=keepassxc-browser-git
+_gitname=keepassxc
+pkgver=2.1.4.r579.g35ffd8f8
+pkgrel=1
+pkgdesc="A reboot of an OpenSource password safe which helps you to manage your passwords in an easy and secure way with a modern browser extension"
+arch=('i686' 'x86_64')
+url="https://github.com/varjolintu/keepassxc"
+license=('GPL2')
+depends=('libxtst' 'shared-mime-info' 'qt5-x11extras' 'hicolor-icon-theme' 'desktop-file-utils' 'yubikey-personalization' 'boost-libs' 'libsodium')
+install=keepassxc-browser.install
+makedepends=('git' 'intltool' 'cmake' 'qt5-base' 'qt5-tools' 'zlib' 'libgcrypt' 'boost')
+conflicts=('keepassxc' 'keepassxc-git')
+replaces=('keepassx-http' 'keepassx-reboot-git')
+options=(!emptydirs)
+source=(git+https://github.com/varjolintu/keepassxc.git#branch=feature/chromeKeePassXC)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_gitname}"
+ mkdir -p build
+}
+
+build() {
+ cd "${_gitname}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_BINDIR=/usr/bin \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_VERBOSE_MAKEFILE=OFF \
+ -DWITH_TESTS=OFF \
+ -DWITH_XC_AUTOTYPE=ON \
+ -DWITH_XC_YUBIKEY=ON \
+ -DWITH_XC_BROWSER=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+#check() {
+# cd "${_gitname}/build"
+# make test
+#}
+
+package() {
+ cd "${_gitname}/build"
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/keepassxc-browser.install b/keepassxc-browser.install
new file mode 100644
index 000000000000..716c0a0d4694
--- /dev/null
+++ b/keepassxc-browser.install
@@ -0,0 +1,19 @@
+post_install() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}