summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422018-12-21 01:29:40 +0100
committerSkycoder422018-12-21 01:29:40 +0100
commitffb05e31f242f81046bedcb85482d61a69c4d537 (patch)
treea361cdaebfdd4e531c236acd989b80399ce13962
downloadaur-ffb05e31f242f81046bedcb85482d61a69c4d537.tar.gz
create package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rw-r--r--clientflags.patch13
-rw-r--r--keepassxc-client-library.rule1
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fce715935f68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = keepassxc-client-library
+ pkgdesc = A C++ library to access the browser-plugin-API of KeePassXC to retrieve or create entries
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Skycoder42/keepassxc-client-library
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = pkgconfig
+ depends = qt5-base
+ depends = libsodium
+ optdepends = repkg: Automatically rebuild the package on dependency updates
+ source = keepassxc-client-library-1.0.0::git+https://github.com/Skycoder42/keepassxc-client-library.git#tag=1.0.0
+ source = clientflags.patch
+ source = keepassxc-client-library.rule
+ sha256sums = SKIP
+ sha256sums = 739d2c8bb3b6637369ebf42a10bdf846f15c6432453b844f9761d3009d00e01f
+ sha256sums = 5c26037370478a522a91354fd1f5504790ec9a1bf46523c433ca1ea4348b4a6f
+
+pkgname = keepassxc-client-library
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..198613113d85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=keepassxc-client-library
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A C++ library to access the browser-plugin-API of KeePassXC to retrieve or create entries"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/keepassxc-client-library"
+license=('BSD')
+depends=('qt5-base' 'libsodium')
+makedepends=('git' 'qt5-tools' 'pkgconfig')
+optdepends=("repkg: Automatically rebuild the package on dependency updates")
+_pkgfqn=$pkgname-$pkgver
+source=("$_pkgfqn::git+https://github.com/Skycoder42/keepassxc-client-library.git#tag=$pkgver"
+ 'clientflags.patch'
+ "$pkgname.rule")
+sha256sums=('SKIP'
+ '739d2c8bb3b6637369ebf42a10bdf846f15c6432453b844f9761d3009d00e01f'
+ '5c26037370478a522a91354fd1f5504790ec9a1bf46523c433ca1ea4348b4a6f')
+
+prepare() {
+ cd "$_pkgfqn"
+ git apply ../clientflags.patch
+ git submodule update --init --recursive
+ cd ..
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake 'CONFIG+=install_demo' 'PREFIX=/usr' "../$_pkgfqn/"
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/system/${pkgname}.rule"
+}
diff --git a/clientflags.patch b/clientflags.patch
new file mode 100644
index 000000000000..5c7c4d989022
--- /dev/null
+++ b/clientflags.patch
@@ -0,0 +1,13 @@
+diff --git a/src/client.h b/src/client.h
+index 4377a14..acb9df6 100644
+--- a/src/client.h
++++ b/src/client.h
+@@ -24,7 +24,7 @@ class KPXCCLIENT_EXPORT Client : public QObject
+ Q_PROPERTY(QByteArray currentDatabase READ currentDatabase NOTIFY currentDatabaseChanged)
+
+ public:
+- enum class Option {
++ enum Option {
+ None = 0x00,
+ AllowNewDatabase = 0x01,
+ TriggerUnlock = 0x02,
diff --git a/keepassxc-client-library.rule b/keepassxc-client-library.rule
new file mode 100644
index 000000000000..7de1fa442085
--- /dev/null
+++ b/keepassxc-client-library.rule
@@ -0,0 +1 @@
+qt5-base libsodium