summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Qia2015-07-16 23:34:53 -0700
committerMax Qia2015-07-16 23:34:53 -0700
commit7a4ee063d3527f329c8e2fc05f8d55ef77368fb6 (patch)
tree25fe17080f83edae99ced208e0dedb0d86b25a2e
parentded28dc992f5b37a146c6b9e41cce40180419a49 (diff)
parent48d05bee663fd8db97e936b34ddf4ed2af40c904 (diff)
downloadaur-7a4ee063d3527f329c8e2fc05f8d55ef77368fb6.tar.gz
Merge branch 'keepassx-http-merge-master'
-rw-r--r--.SRCINFO21
-rw-r--r--[-rwxr-xr-x]PKGBUILD26
-rw-r--r--[-rwxr-xr-x]keepassx.install0
3 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51eab1eda138..dbe539bbf1f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = keepassx-http
- pkgdesc = KeePassX + keepasshttp + autotype
- pkgver = 2.0.alpha5.r254.g4008e6a
+pkgbase = keepassx-http-merge
+ pkgdesc = KeepassX, with eugenesan's merge request for keepasshttp.
+ pkgver = 2.0.alpha6.r235.gf076ad3
pkgrel = 1
- url = https://github.com/jdachtera/keepassx.git
+ url = https://github.com/eugenesan/keepassx/tree/http
install = keepassx.install
arch = i686
arch = x86_64
@@ -10,18 +10,23 @@ pkgbase = keepassx-http
makedepends = git
makedepends = intltool
makedepends = cmake
- makedepends = libmicrohttpd
+ makedepends = zlib
+ makedepends = libgcrypt
depends = libxtst
depends = qt4
depends = shared-mime-info
+ depends = qjson
+ depends = libmicrohttpd
+ optdepends = libxtst: auto-type support
conflicts = keepassx-svn
conflicts = keepassx
conflicts = keepassx2-git
conflicts = keepassx2
+ conflicts = keepassx2-yubikey-git
+ conflicts = keepassx-http
conflicts = keepassx-git
- conflicts = keepassx
- source = git+https://github.com/Ivan0xFF/keepassx.git
+ source = git+https://github.com/eugenesan/keepassx.git#branch=http
md5sums = SKIP
-pkgname = keepassx-http
+pkgname = keepassx-http-merge
diff --git a/PKGBUILD b/PKGBUILD
index 086be77d2abb..ccd101af1816 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,34 @@
-# Maintainer: inkr <i@inkr.ml>
+# Maintainer: Maxqia maxqia@kliznoe.com
-pkgname=keepassx-http
+pkgname=keepassx-http-merge
_gitname=keepassx
-# _upversion=2.0-alpha1
-pkgver=2.0.alpha5.r254.g4008e6a
+pkgver=2.0.alpha6.r235.gf076ad3
pkgrel=1
-pkgdesc="KeePassX + keepasshttp + autotype"
+pkgdesc="KeepassX, with eugenesan's merge request for keepasshttp."
arch=('i686' 'x86_64')
-url="https://github.com/jdachtera/keepassx.git"
+url="https://github.com/eugenesan/keepassx/tree/http"
license=('GPL2')
-depends=('libxtst' 'qt4' 'shared-mime-info')
+depends=('libxtst' 'qt4' 'shared-mime-info' 'qjson' 'libmicrohttpd')
install=keepassx.install
-makedepends=('git' 'intltool' 'cmake' 'libmicrohttpd')
-conflicts=('keepassx-svn' 'keepassx' 'keepassx2-git' 'keepassx2' 'keepassx-git' 'keepassx')
-source=("git+https://github.com/Ivan0xFF/keepassx.git")
-#source=("https://github.com/keithbennett/keepassx/archive/${_upversion}.tar.gz")
+makedepends=('git' 'intltool' 'cmake' 'zlib' 'libgcrypt')
+optdepends=('libxtst: auto-type support')
+conflicts=('keepassx-svn' 'keepassx' 'keepassx2-git' 'keepassx2' 'keepassx2-yubikey-git' 'keepassx-http' 'keepassx-git')
+source=(git+https://github.com/eugenesan/keepassx.git#branch=http)
md5sums=('SKIP')
pkgver() {
cd "${_gitname}"
-# cd "${_gitname}-${_upversion}"
git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${_gitname}"
-# cd "${_gitname}-${_upversion}"
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_BINDIR=/usr/bin -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_VERBOSE_MAKEFILE=ON -DWITH_GUI_TESTS=OFF
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_BINDIR=/usr/bin -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_VERBOSE_MAKEFILE=ON -DWITH_GUI_TESTS=ON
make
}
package() {
cd "${_gitname}"
-# cd "${_gitname}-${_upversion}"
make PREFIX=/usr DESTDIR="${pkgdir}" install
}
diff --git a/keepassx.install b/keepassx.install
index 716c0a0d4694..716c0a0d4694 100755..100644
--- a/keepassx.install
+++ b/keepassx.install