summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaniel6662019-11-29 09:07:43 +0100
committerdaniel6662019-11-29 09:07:43 +0100
commita723ede5bff31b470630b95334c0ea35158569d9 (patch)
treeec6e65c4a85b746c9010a813d449cd9f21bb4674
parentae3439d4d3707358c25fc0d5941a589a47ba1eeb (diff)
downloadaur-a723ede5bff31b470630b95334c0ea35158569d9.tar.gz
Update to 4.9.10
Fixes dependencies. Small fixes in package() function. Installing chromium license. Added .gitignore
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD20
3 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49c7a7bb18c4..f3eff2d195af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = keeper-password-manager
pkgdesc = Keeper is the world's #1 most downloaded password keeper and secure digital vault for protecting and managing your passwords and other secret information.
- pkgver = 14.9.9
+ pkgver = 14.9.10
pkgrel = 1
url = https://keepersecurity.com
arch = x86_64
license = Custom
- depends = xdg-utils
- source = https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_14.9.9_amd64.deb
+ depends = libsecret
+ depends = nss
+ depends = libxss
+ depends = gtk3
+ source = https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_14.9.10_amd64.deb
source = LICENSE
- sha512sums = 60437f858e3f6332870cd2ea979ede137847a5e62971858cae97d0d786344e7852c6c115d91ef3509fe5cfdea5bdbb90f27106fddc60dbdeb5369ab602891038
+ sha512sums = 359fdd89b5ca4b4d7bbdf48df4d37dea0c960f6dc8db7da24290b3b0cb56f8a12228c0256be181948730cd127126278dbf91feb838c28e9480da62ecd748ab0e
sha512sums = 9bd161a552aba146ee89ab930b8a444442d3cb4bba8cf5e94d1a04bfe2c99fae8372d0d04d5b01fe489578429e9fd020cb567e005b1a267fcb51a0bc4cb2f7b2
pkgname = keeper-password-manager
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d72f8ee1f99
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.deb
+keeper-password-manager-*.pkg.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 7c6b4d6693c0..af1914fb3abc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
# Contributor: liberodark
pkgname=keeper-password-manager
-pkgver=14.9.9
+pkgver=14.9.10
pkgrel=1
pkgdesc="Keeper is the world's #1 most downloaded password keeper and secure digital
vault for protecting and managing your passwords and other secret information."
arch=('x86_64')
url="https://keepersecurity.com"
license=('Custom')
-depends=('xdg-utils')
+depends=('libsecret' 'nss' 'libxss' 'gtk3')
source=("https://keepersecurity.com/desktop_electron/Linux/repo/deb/keeperpasswordmanager_${pkgver}_amd64.deb"
'LICENSE')
-sha512sums=('60437f858e3f6332870cd2ea979ede137847a5e62971858cae97d0d786344e7852c6c115d91ef3509fe5cfdea5bdbb90f27106fddc60dbdeb5369ab602891038'
+sha512sums=('359fdd89b5ca4b4d7bbdf48df4d37dea0c960f6dc8db7da24290b3b0cb56f8a12228c0256be181948730cd127126278dbf91feb838c28e9480da62ecd748ab0e'
'9bd161a552aba146ee89ab930b8a444442d3cb4bba8cf5e94d1a04bfe2c99fae8372d0d04d5b01fe489578429e9fd020cb567e005b1a267fcb51a0bc4cb2f7b2')
-package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+package() {
+ bsdtar -xf "$srcdir"/data.tar.xz -C "$pkgdir"
+
+ echo "Setting needed '4755' mode to file: chrome-sandbox."
+ chmod 4755 "$pkgdir"/usr/lib/keeperpasswordmanager/chrome-sandbox
- cd "$srcdir"
- tar xpvf data.tar.xz
- cp -r usr "$pkgdir"
- msg2 "Setting needed '4755' mode to file: chrome-sandbox."
- chmod 4755 "$pkgdir/usr/lib/keeperpasswordmanager/chrome-sandbox"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "$pkgdir"/usr/lib/keeperpasswordmanager/LICENSES.chromium.html "$pkgdir"/usr/share/licenses/chromium/LICENSES.chromium.html
}