summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Hicklen2021-05-21 11:16:50 -0500
committerMike Hicklen2021-05-21 11:16:50 -0500
commitec3b871da62b7cf36784a0fa8ee9e764841b6d8b (patch)
tree0a65c8e7546d4f6c719af319fad6a54949de36ba
parentd9750bfb4b459374a31a660b7395884a4a35be8c (diff)
downloadaur-ec3b871da62b7cf36784a0fa8ee9e764841b6d8b.tar.gz
Adding in permissions update
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a550b6be46..2b7e35ed567f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keeper-password-manager
pkgdesc = Keeper is the world's #1 most downloaded password keeper and secure digital vault for protecting and managing your passwords and other secret information.
pkgver = 16.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://keepersecurity.com
arch = x86_64
license = Custom
diff --git a/PKGBUILD b/PKGBUILD
index 15d4e8af13df..e0859e5197cf 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=keeper-password-manager
pkgver=16.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Keeper is the world's #1 most downloaded password keeper and secure digital
vault for protecting and managing your passwords and other secret information."
arch=('x86_64')
@@ -19,7 +19,12 @@ package() {
echo "Setting needed '4755' mode to file: chrome-sandbox."
chmod 4755 "$pkgdir"/usr/lib/keeperpasswordmanager/chrome-sandbox
-
+ echo "Setting needed '755' mode on directories: resources/*, locales, swiftshader"
+ find "$pkgdir"/usr/lib/keeperpasswordmanager/resources -type d -print0 | xargs -0 chmod 755
+ chmod 755 "$pkgdir"/usr/lib/keeperpasswordmanager/locales/
+ chmod 755 "$pkgdir"/usr/lib/keeperpasswordmanager/swiftshader/
+
+
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm644 "$pkgdir"/usr/lib/keeperpasswordmanager/LICENSES.chromium.html "$pkgdir"/usr/share/licenses/chromium/LICENSES.chromium.html
}