summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Hansen2022-07-19 20:14:30 -0700
committerScott Hansen2022-07-19 20:14:30 -0700
commit37c17e778477c32e92e429b7d5720007c8896d0a (patch)
treee43ff02df717c927a723643083342468bb251e69
parent03a2860c2f52b928474b4279aa3453fb8e3cd8af (diff)
downloadaur-37c17e778477c32e92e429b7d5720007c8896d0a.tar.gz
Switch to python build module instead of setup.py
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1068be311f6e..e9f597d74390 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = keepmenu-git
pkgdesc = Dmenu/Rofi frontend for Keepass databases.
- pkgver = r177.aecb894
+ pkgver = r217.e0d132e
pkgrel = 1
url = https://github.com/firecat53/keepmenu
install = keepmenu.install
arch = any
license = GPL3
makedepends = git
+ makedepends = python-build
+ makedepends = python-setuptools
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-pykeepass
depends = python-pynput
diff --git a/PKGBUILD b/PKGBUILD
index cf23cd2a888f..d99d00555bca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('any')
url="https://github.com/firecat53/keepmenu"
license=('GPL3')
depends=('python' 'python-pykeepass' 'python-pynput')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-build' 'python-setuptools' 'python-installer' 'python-wheel')
optdepends=('dmenu: either dmenu or rofi is required'
'rofi: either dmenu or rofi is required'
'xdotool: required for typing non-U.S. Unicode characters')
@@ -28,12 +28,12 @@ pkgver() {
build() {
cd "$_gitname"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_gitname"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$srcdir/$_gitname/keepmenu.1" "$pkgdir/usr/share/man/man1/keepmenu.1"
}