summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commita6bc5ab3339ef2f2feb75cf6f9a543e0fd310d13 (patch)
tree413f896061e384d75564f00a34095b221b5e01dc
downloadaur-a6bc5ab3339ef2f2feb75cf6f9a543e0fd310d13.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..605bbf2be0d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:59 UTC 2019
+pkgbase = keepnote
+ pkgdesc = GTK+ note taking application
+ pkgver = 0.7.8
+ pkgrel = 4
+ url = http://keepnote.org/
+ arch = any
+ license = GPL
+ depends = pygtk
+ optdepends = python2-gtkspell: spell shecking support
+ source = http://keepnote.org/download/keepnote-0.7.8.tar.gz
+ md5sums = c1e765bb8a07630f717d04117bc1dc58
+
+pkgname = keepnote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87c514501f30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=keepnote
+pkgver=0.7.8
+pkgrel=4
+pkgdesc="GTK+ note taking application"
+arch=('any')
+url="http://keepnote.org/"
+license=('GPL')
+depends=('pygtk')
+optdepends=('python2-gtkspell: spell shecking support')
+source=(http://keepnote.org/download/$pkgname-$pkgver.tar.gz)
+md5sums=('c1e765bb8a07630f717d04117bc1dc58')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Python2 fix
+ sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' keepnote/tarfile.py
+
+ # Fix l10n support
+ rename '.UTF8' '' keepnote/rc/locale/*
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}