summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhxss2021-01-03 21:06:01 +0300
committerhxss2021-01-03 21:06:01 +0300
commit4370c3e6a6c4ae91103eba13ea93500116a29891 (patch)
treec761d47255fe83b5f4c547db7a96e1b069d26c86
downloadaur-4370c3e6a6c4ae91103eba13ea93500116a29891.tar.gz
init commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf985f62e09a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = keeprofi
+ pkgdesc = Access to keepass database using rofi drun menu
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://gitlab.com/hxss-linux/keeprofi
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ makedepends = curl
+ makedepends = jq
+ makedepends = findutils
+ depends = python-pyxdg
+ depends = python-xerox
+ depends = python-pynput
+ depends = python-pykeepass
+ depends = python-keyring
+ depends = desktop-notify
+ provides = keeprofi
+
+pkgname = keeprofi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd754029ed1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sergey Khobta <hxss@ya.ru>
+
+pipname=keeprofi
+pkgname=$pipname
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Access to keepass database using rofi drun menu"
+arch=(any)
+url="https://gitlab.com/hxss-linux/keeprofi"
+license=(MIT)
+depends=(
+ 'python-pyxdg'
+ 'python-xerox'
+ 'python-pynput'
+ 'python-pykeepass'
+ 'python-keyring'
+ 'desktop-notify'
+)
+makedepends=(
+ 'python-pip'
+ 'curl'
+ 'jq'
+ 'findutils'
+)
+provides=($pipname)
+
+pkgver() {
+ curl -s https://pypi.org/pypi/$pipname/json | jq -r .info.version
+}
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install $pipname \
+ --root=$pkgdir \
+ --isolated \
+ --no-user \
+ --no-deps \
+ --ignore-installed \
+ --no-warn-script-location \
+ --quiet
+
+ python -O -m compileall "$pkgdir"
+
+ install -Dm644 $(find $pkgdir -name LICENSE*) \
+ -t "$pkgdir/usr/share/licenses/$pkgname"
+}