summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2021-08-13 18:50:18 +0800
committerPeter Cai2021-08-13 18:50:18 +0800
commit054dd2b735c10fe74ad10b93ba61d68bf8209fb1 (patch)
tree1c5c41e9e5d25251c8216021b447abf5b5037954
parent61afed21d16e3b9f3a3af146479dd2ece4db463f (diff)
downloadaur-054dd2b735c10fe74ad10b93ba61d68bf8209fb1.tar.gz
update to 1.18.7 and fix keeweb-connector
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbfd62f8b53f..3ee12333612c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keeweb
pkgdesc = Desktop password manager compatible with KeePass databases
- pkgver = 1.18.6
- pkgrel = 2
+ pkgver = 1.18.7
+ pkgrel = 1
url = https://keeweb.info
arch = any
license = MIT
@@ -14,9 +14,9 @@ pkgbase = keeweb
depends = electron12
depends = org.freedesktop.secrets
conflicts = keeweb-desktop
- source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.18.6
+ source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.18.7
source = git+https://github.com/keeweb/keeweb-native-modules.git#tag=0.11.7
- source = git+https://github.com/keeweb/keeweb-connect.git#tag=0.3.6
+ source = git+https://github.com/keeweb/keeweb-connect.git#tag=0.3.7
source = package.json.patch.js
source = 67e917af3dcd9d78273774e7061f74d893b5523b.patch
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 86415c7506a3..38a6420f7b89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: surefire@cryptomile.net
+# vim: noexpandtab tabstop=4 shiftwidth=4 softtabstop=4
+# Maintainer: Peter Cai <peter@typeblog.net>
+# Contributor: <surefire@cryptomile.net>
pkgname=keeweb
-pkgver=1.18.6
+pkgver=1.18.7
_electron=electron12
-pkgrel=2
+pkgrel=1
pkgdesc="Desktop password manager compatible with KeePass databases"
arch=('any')
url="https://keeweb.info"
@@ -24,7 +26,7 @@ conflicts=('keeweb-desktop')
source=(
"${pkgname}::git+https://github.com/keeweb/keeweb.git#tag=v${pkgver}"
"git+https://github.com/keeweb/keeweb-native-modules.git#tag=0.11.7"
- "git+https://github.com/keeweb/keeweb-connect.git#tag=0.3.6"
+ "git+https://github.com/keeweb/keeweb-connect.git#tag=0.3.7"
'package.json.patch.js'
'67e917af3dcd9d78273774e7061f74d893b5523b.patch'
)
@@ -60,6 +62,12 @@ prepare() {
-e "/const BundleAnalyzerPlugin/ d" \
-e "/new BundleAnalyzerPlugin({$/, /^\s*})$/ d" \
build/webpack.config.js
+
+ # Patch `getNativeMessagingHostPath` to not rely on the executable path
+ # (in our case, the executable path is the system electron binary)
+ sed -i \
+ -e 's@function getNativeMessagingHostPath() {@function getNativeMessagingHostPath() {\nreturn "/usr/lib/keeweb/keeweb-native-messaging-host";@' \
+ desktop/scripts/util/browser-extension-installer.js
}
build() {